<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#" xmlns:addthis="http://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head >
<meta charset="UTF-8" />
<title>6 Hellraising Horror Movies 2017</title><meta name="viewport" content="width=device-width, initial-scale=1" />

		<style type="text/css">
			.slide-excerpt { width: 100%; }
			.slide-excerpt { Top: 0; }
			.slide-excerpt { Left: 0; }
			.flexslider { max-width: 737px; max-height: 400px; }
			.slide-image { max-height: 400px; }
		</style>
		<style type="text/css">
			@media only screen
			and (min-device-width : 320px)
			and (max-device-width : 480px) {
				.slide-excerpt { display: none !important; }
			}
		</style> 
<!-- This site is optimized with the Yoast SEO plugin v4.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Our pick of horror movies 2017 edition; not just horror movies, mind you. HELLRAISING horror movies."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="6 Hellraising Horror Movies 2017" />
<meta property="og:description" content="Our pick of horror movies 2017 edition; not just horror movies, mind you. HELLRAISING horror movies." />
<meta property="og:url" content="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/" />
<meta property="og:site_name" content="ForeverGeek" />
<meta property="article:publisher" content="https://www.facebook.com/forevergeek.blog" />
<meta property="article:tag" content="Horror Movies" />
<meta property="article:tag" content="Movies" />
<meta property="article:section" content="Movies &amp; Television" />
<meta property="article:published_time" content="2017-02-24T09:00:44-05:00" />
<meta property="article:modified_time" content="2017-02-21T22:26:59-05:00" />
<meta property="og:updated_time" content="2017-02-21T22:26:59-05:00" />
<meta property="og:image" content="http://www.forevergeek.com/wp-content/media/2017/02/belko.png" />
<meta property="og:image:width" content="609" />
<meta property="og:image:height" content="398" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Our pick of horror movies 2017 edition; not just horror movies, mind you. HELLRAISING horror movies." />
<meta name="twitter:title" content="6 Hellraising Horror Movies 2017" />
<meta name="twitter:site" content="@geekforever" />
<meta name="twitter:image" content="http://www.forevergeek.com/wp-content/media/2017/02/belko.png" />
<meta name="twitter:creator" content="@geekforever" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.forevergeek.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Feed" href="http://www.forevergeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Comments Feed" href="http://www.forevergeek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; 6 Hellraising Horror Movies to Keep An Eye Out for in 2017 Comments Feed" href="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.forevergeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='pibfi_pinterest_style-css'  href='http://www.forevergeek.com/wp-content/plugins/pinterest-pin-it-button-for-images/ppibfi_pinterest.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='news-pro-theme-css'  href='http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='http://www.forevergeek.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.forevergeek.com/wp-includes/css/dashicons.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='http://www.forevergeek.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='http://www.forevergeek.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.forevergeek.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css-css'  href='http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/css/custom.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.forevergeek.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://www.forevergeek.com/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/pinterest-pin-it-button-for-images/ppibfi_pinterest.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://www.forevergeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.forevergeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.forevergeek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='http://wp.me/pLeUT-jwF' />
<link rel="alternate" type="application/json+oembed" href="http://www.forevergeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.forevergeek.com%2F2017%2F02%2Fhellraising-horror-movies-2017%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.forevergeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.forevergeek.com%2F2017%2F02%2Fhellraising-horror-movies-2017%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/favicon.png" />
<link rel="pingback" href="http://www.forevergeek.com/xmlrpc.php" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4829570-3', 'auto');
  ga('send', 'pageview');

</script>

<meta name="google-site-verification" content="oV-Ua2VGHAYSk8L0RfBgjNLNotbED-4qeoERwVuI1os" /></head>
<body class="post-template-default single single-post postid-75061 single-format-standard desktop ie content-sidebar" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title"><a href="http://www.forevergeek.com" title="ForeverGeek"><img class="site-logo" src="http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/logo.png" alt="ForeverGeek logo"></a></p></div><div class="widget-area header-widget-area"><section id="text-38" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><style type="text/css">
#responsiveleaderboard { max-width: 800px; overflow:hidden; margin: 0 auto; }
@media (min-width: 1024px) and (max-width: 1188px) {
  #responsiveleaderboard { max-width: 580px; }
}
@media (min-width: 768px) and (max-width: 1023px) {
  #responsiveleaderboard { max-width: 728px; }
}
@media (max-width: 767px) {
  #responsiveleaderboard { max-width: 468px; }
}
</style>

<div id = "responsiveleaderboard">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FG 728x90 leader responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6912717002762685"
     data-ad-slot="4973535492"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div><!--/#responsiveleaderboard--></div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-header-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-64951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64951"><a href="http://www.forevergeek.com/category/features/" itemprop="url"><span itemprop="name">Features</span></a></li>
<li id="menu-item-64952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64952"><a href="http://www.forevergeek.com/category/cool-stuff-geekery/" itemprop="url"><span itemprop="name">Cool Stuff &#038; Geekery</span></a></li>
<li id="menu-item-64953" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64953"><a href="http://www.forevergeek.com/category/movies-television/" itemprop="url"><span itemprop="name">Movies &#038; TV</span></a></li>
<li id="menu-item-64954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64954"><a href="http://www.forevergeek.com/category/anime-comics/" itemprop="url"><span itemprop="name">Anime &#038; Comics</span></a></li>
<li id="menu-item-66222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66222"><a href="http://www.forevergeek.com/category/games/" itemprop="url"><span itemprop="name">Games</span></a></li>
<li id="menu-item-64955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64955"><a href="#" itemprop="url"><span itemprop="name">More!</span></a>
<ul class="sub-menu">
	<li id="menu-item-64960" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64960"><a href="http://www.forevergeek.com/category/general/" itemprop="url"><span itemprop="name">General</span></a></li>
	<li id="menu-item-64957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64957"><a href="http://www.forevergeek.com/archive/" itemprop="url"><span itemprop="name">Archives</span></a></li>
	<li id="menu-item-64958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64958"><a href="http://www.forevergeek.com/about/" itemprop="url"><span itemprop="name">About ForeverGeek</span></a></li>
	<li id="menu-item-64959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64959"><a href="http://www.forevergeek.com/contact/" itemprop="url"><span itemprop="name">Contact</span></a></li>
	<li id="menu-item-64956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64956"><a href="http://www.forevergeek.com/terms-privacy/" itemprop="url"><span itemprop="name">Terms &#038; Privacy</span></a></li>
</ul>
</li>
<li class="right social"><a href="https://www.pinterest.com/forevergeek/"><span class="genericon genericon-pinterest"></span></a></li><li class="right social"><a href="https://twitter.com/geekforever"><span class="genericon genericon-twitter"></span></a></li><li class="right social"><a href="https://www.facebook.com/forevergeek.blog"><span class="genericon genericon-facebook-alt"></span></a></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-75061 post type-post status-publish format-standard has-post-thumbnail category-movies-television tag-horror-movies tag-movies entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">6 Hellraising Horror Movies to Keep An Eye Out for in 2017</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-02-24T09:00:44+00:00">February 24, 2017</time> by <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://www.forevergeek.com/author/remy-carreiro/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Remy Carreiro</span></a></span> <span class="entry-comments-link"><a href="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><img width="609" height="398" src="http://www.forevergeek.com/wp-content/media/2017/02/belko.png" class="attachment-large size-large wp-post-image" alt="" srcset="http://www.forevergeek.com/wp-content/media/2017/02/belko.png 609w, http://www.forevergeek.com/wp-content/media/2017/02/belko-470x307.png 470w" sizes="(max-width: 609px) 100vw, 609px" /></p><div class="before-entry" class="widget-area"><section id="text-40" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FG below featured image posts -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-6912717002762685"
     data-ad-slot="3496802290"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</div>
		</div></section>
</div><!-- AddThis Sharing Buttons above -->
                <div class="addthis_toolbox addthis_default_style addthis_32x32_style" addthis:url='http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/' addthis:title='6 Hellraising Horror Movies to Keep An Eye Out for in 2017' >
                    <a class="addthis_button_preferred_1"></a>
                    <a class="addthis_button_preferred_2"></a>
                    <a class="addthis_button_preferred_3"></a>
                    <a class="addthis_button_preferred_4"></a>
                    <a class="addthis_button_compact"></a>
                    <a class="addthis_counter addthis_bubble_style"></a>
                </div><p>&#8220;Horror&#8221; is a very subjective word and genre. Horror means different things to different people. I could be afraid of spiders and you could have one as a pet. You could be afraid of heights and I can tell you about the massive erection I got while skydiving.</p>
<p>It is just how the instinct of fear works. It bites us all in different spots with different doses of venom. And the horror movie genre is a perfect example of this. A widely varying genre that tends to cover everything from creaky doors and jump scares to straight up stomach turning gore (I watched a movie where a woman got a baby got out of her two nights ago, <a href="https://www.youtube.com/watch?v=ibP9PUdEmwk">for realsies</a>), horror movies may not be for everyone but the irony here is, they actually ARE.</p>
<p>No matter what you fear, there is at least ONE movie out there that touches on it. Really.</p>
<p>So for other fans of horror films much like myself, here are 6 horror movies to keep an eye out for (literally, gouge that bitch out) in 2017! Please note they are presented in no particular order and you won&#8217;t find any whack-ass sequels on this list. Well, maybe ONE, but I have high hopes for it.<span id="more-75061"></span></p>
<h2>Horror movies 2017</h2>
<h3 style="text-align: center;"><strong>Get Out</strong></h3>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/A2JbO9lnVLE?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;start=2&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>So Jordan Peele from Key and Peele wrote and directed a horror movie about racial tensions in a weird, gothic looking Southern town and from what I have heard (I know people who know people who have heard of people who once met people who know important people) the film is really unsettling and quite good, with a fantastic cast and a story that seems perfectly timed in these tumultuous&#8230;um, times.</p>
<p>In other words, straight up, racial tensions in this world are at an all time high so to have the balls to address that and scare that crap out of us at the same time has Get Out at the top of my &#8220;Must-See&#8217; 2017 horror movies. Plus it is well known that neither Key OR Peele can do any wrong.</p>
<p>Go watch Keanu, you think I&#8217;m lying.</p>
<h3 style="text-align: center;">It</h3>
<p>
		<span class="pibfi_pinterest ">
		<img class="aligncenter size-full wp-image-75063" src="http://www.forevergeek.com/wp-content/media/2017/02/shit.png" alt="" width="599" height="314" srcset="http://www.forevergeek.com/wp-content/media/2017/02/shit.png 599w, http://www.forevergeek.com/wp-content/media/2017/02/shit-470x246.png 470w" sizes="(max-width: 599px) 100vw, 599px" />
			<span class="xc_pin" onclick="pin_this(event, 'http://pinterest.com/pin/create/button/?url=http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/&amp;media=http://www.forevergeek.com/wp-content/media/2017/02/shit.png&amp;description=6 Hellraising Horror Movies to Keep An Eye Out for in 2017')">
			</span>
		</span>
	</p>
<p><strong>Me</strong><em>: Well, looks like we are finally getting It.</em></p>
<p><strong>Ambiguous other person</strong><em>: Getting what, Remy?</em></p>
<p><strong>Me</strong><em>: It.</em></p>
<p><strong>The other dude</strong><em>: What&#8217;s It?</em></p>
<p><strong>Me</strong><em>: It&#8217;s It!</em></p>
<p><strong>That dude again</strong><em>: WHAT IS IT?</em></p>
<p><strong>Me</strong><em>: Are you singing <a href="https://www.youtube.com/watch?v=ZG_k5CSYKhg" target="_blank">Faith No More</a> or asking me a question?</em></p>
<p><strong>Stranger, who is still ambiguous, mind you</strong><em>: You lost me kid, now what is all this IT talk about?</em></p>
<p><strong>Me</strong><em>: You know, the cinematic remake of the TV movie based on the Stephen King story a clown that terrorizes some kids specifically in Maine and then they gangbang their female friend in the forest and then kill the clown when it turns into a giant spider in a fucking cave. You know, THAT It?</em></p>
<p><strong><em>*Person says &#8220;That&#8217;s it&#8221; and walks away.</em></strong></p>
<p><em>I say EXACTLY and the scene ends and I win an Emmy for writing.</em></p>
<p>That was awesome, I know, thank you, but we need to talk about It. Something NO ONE says. The It TV movie sucked and we have overhyped it in our heads because of our memories of Tim Curry (who OWNED the Pennywise role but was in movie for about ten minutes altogether).</p>
<p>Think I am lying? There was a scene with stop motion fortune cookie monsters in the original that was the UNSCARIEST thing I have ever seen and that is not even a real word. Oh, you forgot about those fortune cookie creatures, huh? So did the world, apparently?</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/RbL7Ri2TgcQ?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>So as long as they darken it up a LOT and Pennywise STILL makes us crap our pants, I am there. But they better include the gangbang scene from the book this time. Just kidding, that was the freakiest part of the fucking book. Get it, fucking book cuz the kids were fucking?</p>
<p><em>*shudders</em></p>
<h3 style="text-align: center;">Alien: Covenant</h3>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/H0VW6sg50Pk?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Here&#8217;s my whack-ass sequel entry that I really believe won&#8217;t be whack-ass. Just the simple fact that someone gave Neill Blomkamp the reins to direct a new Alien movie (that seems like it may breach the untold timeline between Prometheus and Alien) is reason to celebrate. Few do Sci-Fi as well as Blomkamp and the world needs another tense, claustrophobic, gory, SCARY Alien movie (which the trailer teases at, big time).</p>
<p>Rumor is this is the end of it the Alien films (which will not be the case when it makes billions) and Neill says he is doing it right in tying it all together. But fuck yes. If it is even half as scary as the first two this movie will own 2017, and remind us that xenomorphs are as scary as bill collectors and twice as aggressive.</p>
<h3 style="text-align: center;">A Cure for Wellness</h3>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/JF1rLFCdewU?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>So this one may pretty much be out already and is getting great reviews which makes this entry a &#8220;duh&#8221;, I still felt the need to put a &#8220;psychological thriller&#8221; on this list, and  A Cure for Wellness is just that. A disturbing dive into the way mental wards used to work, as well as an inevitable ending that mirrors Shutter Island. Come on, we all know that&#8217;s gonna happen but this looks good enough to forgive.</p>
<p>But just the look and feel of it seems intriguing and chilling, and Dane DeHaan is a great up-and-coming actor so that also has me lining up. What sealed the deal for me was the naked chick in the snake tub. Anytime there is a naked chick in a tub filled with snakes, I am there with my d*ck out.</p>
<p>Sorry, I keep shit real.</p>
<h3 style="text-align: center;">The Belko Experiment</h3>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/hCl0bOwq62c?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Listen, if I had an office job and one day I went in and they locked us down and told us we had to kill people to live, ALL MY MOTHERFUCKING COWORKERS WOULD BE DEAD, YA&#8217;LL. I am talking heads through copy machines, fucking pencil sharpeners being fed fingers and shit. That is basically what The Belko Experiment is about. You want this job, so do they, kill them.</p>
<p>Oh, and it was written by James Gunn who wrote Guardians of the Galaxy and is pretty much incapable of delivering a bad movie. So there&#8217;s that, too. It is like Office Space meets Battle Roya&#8230;.nope. That fruit is just too low hanging, and I am better than that.</p>
<h3 style="text-align: center;">Some Foreign Horror Film I Don&#8217;t Know of Yet</h3>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/aJTOEYnfszg?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>I want to lean towards the aforementioned unnamed horror film being Japanese or maybe even South Korean in creation, but my real money is on the French. Those peeps put out some disturbing shit every year that always tends to fly right under the radar, when it shouldn&#8217;t. High Tension, Inside, and Martyrs are some of the best horror films ever made and they are all French.</p>
<p>Hell, the above trailer has tits and mermaids so there ya go. May not be French, but it isn&#8217;t American and it looks ballsy as shit.</p>
<p>What I am saying here is, fuck <a href="http://www.forevergeek.com/2014/10/movie-annabelle/" target="_blank">Annabelle 2</a>, fuck Insidious 4, fuck all the damned retreads of the same shitty horror movies we get every fucking year and find something unique and appalling (and appealing) to go see outside the mainstream, preferably foreign so you get a better scope for how horror is handled internationally.</p>
<p><em><strong><a href="http://birthmoviesdeath.com/2015/09/11/child-molester-victor-salva-directing-third-jeepers-creepers-movie" target="_blank">And DO NOT SEE JEEPERS CREEPERS 3. That director rapes kids. </a></strong></em></p>
<p><em>How is that for fucking horrifying? Someone should make a horror movie where he gets hung. I&#8217;d pay to see that.</em></p>
<script data-cfasync="false" type="text/javascript">
var addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":300,"ignore_server_config":true};
var addthis_share = {};
</script>
                <!-- AddThis Settings Begin -->
                <script data-cfasync="false" type="text/javascript">
                    var addthis_product = "wpp-5.3.4";
                    var wp_product_version = "wpp-5.3.4";
                    var wp_blog_version = "4.7.2";
                    var addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"5.3.4","anonymous_profile_id":"wp-05693716ff6d9068c10caa888a1e37c7","plugin_mode":"WordPress","select_prefs":{"addthis_per_post_enabled":true,"addthis_above_enabled":true,"addthis_below_enabled":true,"addthis_sidebar_enabled":false,"addthis_mobile_toolbar_enabled":true,"addthis_above_showon_home":false,"addthis_above_showon_posts":true,"addthis_above_showon_pages":false,"addthis_above_showon_archives":false,"addthis_above_showon_categories":false,"addthis_above_showon_excerpts":false,"addthis_below_showon_home":false,"addthis_below_showon_posts":true,"addthis_below_showon_pages":false,"addthis_below_showon_archives":false,"addthis_below_showon_categories":false,"addthis_below_showon_excerpts":false,"addthis_sidebar_showon_home":true,"addthis_sidebar_showon_posts":true,"addthis_sidebar_showon_pages":true,"addthis_sidebar_showon_archives":true,"addthis_sidebar_showon_categories":true,"addthis_mobile_toolbar_showon_home":true,"addthis_mobile_toolbar_showon_posts":true,"addthis_mobile_toolbar_showon_pages":true,"addthis_mobile_toolbar_showon_archives":true,"addthis_mobile_toolbar_showon_categories":true,"sharing_enabled_on_post_via_metabox":true},"page_info":{"template":"posts","post_type":""}};
                    if (typeof(addthis_config) == "undefined") {
                        var addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":300,"ignore_server_config":true};
                    }
                    if (typeof(addthis_share) == "undefined") {
                        var addthis_share = {};
                    }
                    if (typeof(addthis_layers) == "undefined") {
                        var addthis_layers = {"sharedock":{"counts":true,"position":"bottom","numPreferredServices":4}};
                    }
                </script>
                <script
                    data-cfasync="false"
                    type="text/javascript"
                    src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b76011022e6a2e "
                    async="async"
                >
                </script>
                <script data-cfasync="false" type="text/javascript">
                    (function() {
                        var at_interval = setInterval(function () {
                            if(window.addthis) {
                                clearInterval(at_interval);
                                addthis.layers(addthis_layers);
                            }
                        },1000)
                    }());
                </script>
                <!-- AddThis Sharing Buttons below -->
                <div class="addthis_toolbox addthis_default_style addthis_32x32_style" addthis:url='http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/' addthis:title='6 Hellraising Horror Movies to Keep An Eye Out for in 2017' >
                    <a class="addthis_button_preferred_1"></a>
                    <a class="addthis_button_preferred_2"></a>
                    <a class="addthis_button_preferred_3"></a>
                    <a class="addthis_button_preferred_4"></a>
                    <a class="addthis_button_compact"></a>
                    <a class="addthis_counter addthis_bubble_style"></a>
                </div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/"
    dc:identifier="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/"
    dc:title="6 Hellraising Horror Movies to Keep An Eye Out for in 2017"
    trackback:ping="http://www.forevergeek.com/2017/02/hellraising-horror-movies-2017/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><div class="after-entry" class="widget-area"><section id="text-31" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_responsive_sharing"></div>
</div>
		</div></section>
</div><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://www.forevergeek.com/category/movies-television/" rel="category tag">Movies &amp; Television</a></span> <span class="entry-tags">Tagged With: <a href="http://www.forevergeek.com/tag/horror-movies/" rel="tag">Horror Movies</a>, <a href="http://www.forevergeek.com/tag/movies/" rel="tag">Movies</a></span></p></footer></article>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/hellraising-horror-movies-2017/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.forevergeek.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="cptch_block"><span class="cptch_title">Please prove you&#039;re human<span class="required"> *</span></span><span class="cptch_wrap">
				<label class="cptch_label" for="cptch_input_55">
					<span class="cptch_span">8</span>
					<span class="cptch_span">&nbsp;&times;&nbsp;</span>
					<span class="cptch_span">&#115;&#101;&#118;en</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_55" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="QbrZ" />
					<input type="hidden" name="cptch_time" value="1487985631" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='75061' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d4d4840faa" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="85"/></p>			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><div class='widget atf'><script src='http://www.googletagservices.com/tag/js/gpt.js'>googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_ATF', [300, 250]).display();</script></div><section id="text-37" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">
<a href="https://feeds.feedburner.com/ForeverGeek"><img src="http://www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png"></a>
</div>
		</div></section>
<section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="http://www.forevergeek.com/" role="search"><meta itemprop="target" content="http://www.forevergeek.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-36" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://www.forevergeek.com/2016/01/5-retro-video-games-that-are-still-fun-to-play/" target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/06/Old-school-video-games.jpg"></a>
<br>
<br>
<br>
<br>
<a href="http://www.forevergeek.com/2014/01/sonic-the-hedgehog-sexy-cosplay/"  target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/06/Sonic-the-Hedgehog-Sexy-Cosplay.jpg"></a>
<br>
<br>
<br>
<br>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FG 300x600 Large Skyscraper -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-6912717002762685"
     data-ad-slot="4438984693"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

<br>
<br>
<br>
<br>

<div id="zergnet-widget-14299"></div>

<script language="javascript" type="text/javascript">
	(function() {
		var zergnet = document.createElement('script');
		zergnet.type = 'text/javascript'; zergnet.async = true;
		zergnet.src = 'http://www.zergnet.com/zerg.js?id=14299';
		var znscr = document.getElementsByTagName('script')[0];
		znscr.parentNode.insertBefore(zergnet, znscr);
	})();
</script>
<br>
<br>
<br>
<br></div>
		</div></section>
<section id="text-35" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://www.forevergeek.com/2015/11/5-geeky-cutting-boards/" target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/05/Geeky-Cutting-Boards-1.jpg"></a>
<br>
<br></div>
		</div></section>
<section id="text-34" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://www.forevergeek.com/2016/01/why-kylo-ren-is-wildly-misunderstood-and-may-be-best-star-wars-villain-yet/"  target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/05/Kylo-Ren-Best-Villain-1.jpg"></a></div>
		</div></section>
<div class='widget btf'><script src='http://www.googletagservices.com/tag/js/gpt.js'>googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_BTF', [300, 250]).display();</script></div></aside></div></div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><p>ForeverGeek &#x000A9;&nbsp;2017 Splashpress Media</p></div></footer></div>	<div style="display:none">
	</div>
<script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "fade",directionNav: ,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script><script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<link rel='stylesheet' id='addthis_output-css'  href='http://www.forevergeek.com/wp-content/plugins/addthis/css/output.css?ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201708'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"b050c0c4c6","ajaxurl":"http:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","enlarge":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/captcha/js/front_end_script.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201708.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'11258759',post:'75061',tz:'-5',srv:'www.forevergeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '11258759', '75061' ]);
</script>
<!--wp_footer--></body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced
Fragment Caching 4/4 fragments using disk

 Served from: forevergeek.com @ 2017-02-24 20:20:31 by W3 Total Cache -->