<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#" xmlns:addthis="http://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head >
<meta charset="UTF-8" />
<title>5 Indie Games to Keep An Eye Out for in 2017</title><meta name="viewport" content="width=device-width, initial-scale=1" />

		<style type="text/css">
			.slide-excerpt { width: 100%; }
			.slide-excerpt { Top: 0; }
			.slide-excerpt { Left: 0; }
			.flexslider { max-width: 737px; max-height: 400px; }
			.slide-image { max-height: 400px; }
		</style>
		<style type="text/css">
			@media only screen
			and (min-device-width : 320px)
			and (max-device-width : 480px) {
				.slide-excerpt { display: none !important; }
			}
		</style> 
<!-- This site is optimized with the Yoast SEO plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="I write up indie games a lot because I think they have a charm and accessibility most big titles lack these days. A game like Inside, anyone can pick up an"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.forevergeek.com/2017/04/indie-games-2017/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="5 Indie Games to Keep An Eye Out for in 2017" />
<meta property="og:description" content="I write up indie games a lot because I think they have a charm and accessibility most big titles lack these days. A game like Inside, anyone can pick up an" />
<meta property="og:url" content="http://www.forevergeek.com/2017/04/indie-games-2017/" />
<meta property="og:site_name" content="ForeverGeek" />
<meta property="article:publisher" content="https://www.facebook.com/forevergeek.blog" />
<meta property="article:tag" content="indie games" />
<meta property="article:tag" content="video games" />
<meta property="article:section" content="Games" />
<meta property="article:published_time" content="2017-04-21T10:00:57-04:00" />
<meta property="article:modified_time" content="2017-04-19T03:55:04-04:00" />
<meta property="og:updated_time" content="2017-04-19T03:55:04-04:00" />
<meta property="og:image" content="http://www.forevergeek.com/wp-content/media/2017/04/des.png" />
<meta property="og:image:width" content="613" />
<meta property="og:image:height" content="362" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="I write up indie games a lot because I think they have a charm and accessibility most big titles lack these days. A game like Inside, anyone can pick up an" />
<meta name="twitter:title" content="5 Indie Games to Keep An Eye Out for in 2017" />
<meta name="twitter:site" content="@geekforever" />
<meta name="twitter:image" content="http://www.forevergeek.com/wp-content/media/2017/04/des.png" />
<meta name="twitter:creator" content="@geekforever" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.forevergeek.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Feed" href="http://www.forevergeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Comments Feed" href="http://www.forevergeek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; 5 Indie Games to Keep An Eye Out for in 2017 Comments Feed" href="http://www.forevergeek.com/2017/04/indie-games-2017/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.forevergeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='pibfi_pinterest_style-css'  href='http://www.forevergeek.com/wp-content/plugins/pinterest-pin-it-button-for-images/ppibfi_pinterest.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='news-pro-theme-css'  href='http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='http://www.forevergeek.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.forevergeek.com/wp-includes/css/dashicons.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='http://www.forevergeek.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='http://www.forevergeek.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.forevergeek.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css-css'  href='http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/css/custom.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.forevergeek.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://www.forevergeek.com/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/pinterest-pin-it-button-for-images/ppibfi_pinterest.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://www.forevergeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.forevergeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.forevergeek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://wp.me/pLeUT-jEs' />
<link rel="alternate" type="application/json+oembed" href="http://www.forevergeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.forevergeek.com%2F2017%2F04%2Findie-games-2017%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.forevergeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.forevergeek.com%2F2017%2F04%2Findie-games-2017%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/favicon.png" />
<link rel="pingback" href="http://www.forevergeek.com/xmlrpc.php" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4829570-3', 'auto');
  ga('send', 'pageview');

</script>

<meta name="google-site-verification" content="oV-Ua2VGHAYSk8L0RfBgjNLNotbED-4qeoERwVuI1os" /></head>
<body class="post-template-default single single-post postid-75544 single-format-standard desktop chrome content-sidebar" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title"><a href="http://www.forevergeek.com" title="ForeverGeek"><img class="site-logo" src="http://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/logo.png" alt="ForeverGeek logo"></a></p></div><div class="widget-area header-widget-area"><section id="text-38" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><style type="text/css">
#responsiveleaderboard { max-width: 800px; overflow:hidden; margin: 0 auto; }
@media (min-width: 1024px) and (max-width: 1188px) {
  #responsiveleaderboard { max-width: 580px; }
}
@media (min-width: 768px) and (max-width: 1023px) {
  #responsiveleaderboard { max-width: 728px; }
}
@media (max-width: 767px) {
  #responsiveleaderboard { max-width: 468px; }
}
</style>

<div id = "responsiveleaderboard">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FG 728x90 leader responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6912717002762685"
     data-ad-slot="4973535492"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div><!--/#responsiveleaderboard--></div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-header-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-64951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64951"><a href="http://www.forevergeek.com/category/features/" itemprop="url"><span itemprop="name">Features</span></a></li>
<li id="menu-item-64952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64952"><a href="http://www.forevergeek.com/category/cool-stuff-geekery/" itemprop="url"><span itemprop="name">Cool Stuff &#038; Geekery</span></a></li>
<li id="menu-item-64953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64953"><a href="http://www.forevergeek.com/category/movies-television/" itemprop="url"><span itemprop="name">Movies &#038; TV</span></a></li>
<li id="menu-item-64954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64954"><a href="http://www.forevergeek.com/category/anime-comics/" itemprop="url"><span itemprop="name">Anime &#038; Comics</span></a></li>
<li id="menu-item-66222" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-66222"><a href="http://www.forevergeek.com/category/games/" itemprop="url"><span itemprop="name">Games</span></a></li>
<li id="menu-item-64955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64955"><a href="#" itemprop="url"><span itemprop="name">More!</span></a>
<ul class="sub-menu">
	<li id="menu-item-64960" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64960"><a href="http://www.forevergeek.com/category/general/" itemprop="url"><span itemprop="name">General</span></a></li>
	<li id="menu-item-64957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64957"><a href="http://www.forevergeek.com/archive/" itemprop="url"><span itemprop="name">Archives</span></a></li>
	<li id="menu-item-64958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64958"><a href="http://www.forevergeek.com/about/" itemprop="url"><span itemprop="name">About ForeverGeek</span></a></li>
	<li id="menu-item-64959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64959"><a href="http://www.forevergeek.com/contact/" itemprop="url"><span itemprop="name">Contact</span></a></li>
	<li id="menu-item-64956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64956"><a href="http://www.forevergeek.com/terms-privacy/" itemprop="url"><span itemprop="name">Terms &#038; Privacy</span></a></li>
</ul>
</li>
<li class="right social"><a href="https://www.pinterest.com/forevergeek/"><span class="genericon genericon-pinterest"></span></a></li><li class="right social"><a href="https://twitter.com/geekforever"><span class="genericon genericon-twitter"></span></a></li><li class="right social"><a href="https://www.facebook.com/forevergeek.blog"><span class="genericon genericon-facebook-alt"></span></a></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-75544 post type-post status-publish format-standard has-post-thumbnail category-games tag-indie-games tag-video-games entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">5 Indie Games to Keep An Eye Out for in 2017</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-04-21T10:00:57+00:00">April 21, 2017</time> by <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://www.forevergeek.com/author/remy-carreiro/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Remy Carreiro</span></a></span> <span class="entry-comments-link"><a href="http://www.forevergeek.com/2017/04/indie-games-2017/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><img width="613" height="362" src="http://www.forevergeek.com/wp-content/media/2017/04/des.png" class="attachment-large size-large wp-post-image" alt="" srcset="http://www.forevergeek.com/wp-content/media/2017/04/des.png 613w, http://www.forevergeek.com/wp-content/media/2017/04/des-470x278.png 470w" sizes="(max-width: 613px) 100vw, 613px" /></p><div class="before-entry" class="widget-area"><section id="text-40" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FG below featured image posts -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-6912717002762685"
     data-ad-slot="3496802290"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</div>
		</div></section>
</div><!-- AddThis Sharing Buttons above --><div class="addthis_toolbox addthis_default_style addthis_32x32_style" addthis:url='http://www.forevergeek.com/2017/04/indie-games-2017/' ><a class="addthis_button_facebook"></a><a class="addthis_button_twitter"></a><a class="addthis_button_pinterest_share"></a><a class="addthis_button_google_plusone_share"></a><a class="addthis_button_reddit"></a></div><p>I write up indie games a lot because I think they have a charm and accessibility most big titles lack these days. A game like Inside, anyone can pick up and play. Anyone. Whereas, if you gave a controller to someone and asked them to play any of the Arkham games, it would take them 30-60 minutes to get the hang of all the gadgets and devices you could can use as the caped crusader.</p>
<p>There is also an intimacy to indie games that lack in big, polished games. You can <a href="http://www.forevergeek.com/2017/01/best-video-games-2017/" target="_blank">play a game</a> like A Night in the Woods and tell you are dealing with something very personal and intimate to the creator, whereas a game like Horizon Zero Dawn (as perfect as it is) lacks that intimacy. Make sense? Well, regardless, I am still going to write about 5 indie games you will all need to pick up and play by the end of 2017.<span id="more-75544"></span></p>
<h2>Keep an eye out for these indie games</h2>
<h2 style="text-align: center;">Kona</h2>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/Qrisf0b_8XE?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Have you ever wondered what it would be like to be stranded in the cold, lonely, icy tundra of Canada while a blizzard wreaks havoc on everything around you? Well, good news if you happened to answer yes, as Kona is just that game.</p>
<p>Still mostly shrouded in mystery, but we know it is going to be released in installments (which is always pretty cool) and you will be a part of a much bigger story than first appears. Looks to have some seriously scary elements as well.</p>
<p>Either way, I&#8217;m keeping my eyes peeled for this one.</p>
<h2 style="text-align: center;">Beautiful Desolation</h2>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/1IkbdiJCrwo?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Keeping in themes that the first game presented, Beautiful Desolation is developed by Brotherhood (who did last year&#8217;s creepy stunner, Stasis) and that alone has me dialed in to Desolation. Stasis was scary in an old-school meets new-school kind of way, and the game immersed me (pun intended, as it took place underwater) like few others did last year.</p>
<p>So what is Beautiful Desolation about?</p>
<p>All we know is it takes place in a Post-apocalyptic version of Africa and it looks stunning. Little else is known but little else needs to be known to get drooling.</p>
<h2 style="text-align: center;">Perception</h2>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/2X2-cz4vIZU?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>A horror game made by some of the team behind the first Bioshock in which you have to use echolocation to see and move around. The trailers and teasers of this game have left my jaw on the floor. Something about the world in this game seems palpably real, and the sense of isolation, even in the trailers, is omnipresent.</p>
<p>Also, the idea of having a protagonist in a game being someone with a disability (wherein that disability becomes a useful gift) is a cool and unique way to go with &#8220;hero of game&#8221; trope, so cannot wait to see and hear (another bad set of puns) more about Perception as it drops.</p>
<h2 style="text-align: center;">Ghost of a Tale</h2>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/9rfuK3u7_oc?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>God bless Kickstarter, huh? In this game I kind of wish I helped fund, you play an old school Adventure game as a mouse. Yup, a cute, little Disney-esque mouse. But do not let the visage scare you off. This is no child&#8217;s game. There will be stealth, quests you can take from NPC&#8217;s, and there are even rumors of dialogue choices. And the graphics bring to mind Disney and the comic Mouse Guard, both of which are great things to be compared to.</p>
<p>Basically, this looks like Disney and Lucasarts finally teamed up to make the dream game they&#8217;ll never make. Now let&#8217;s just pray this indie can live up to such heights I place it on.</p>
<h2 style="text-align: center;">Below</h2>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='http://www.youtube.com/embed/qnjK2BlrQhM?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Below looks stunning, and I won&#8217;t lie when I say that is what drew me in here, big time. Though the characters look TINY, the detail in each animation is staggering, and the scale of the whole thing (you are VERY small) peaks my interest. It has that whole &#8220;brutal but fair&#8221; combat thing going for that all games seem to rock now, with Below also having a big emphasis on exploration.</p>
<p>But everything from the dank look of the underverse you explore to the haunting music that accompanies the ambient soundtrack, Below will definitely steal some hours from me when it comes out (hopefully, as expected, this year). I am also expecting some HUGE enemy encounters seeing as the protagonist is an inch tall but the screen reaches for miles. Yup, sign me up, stat!</p>
<p><em>So what indie game are YOU most looking forward to this year? Take to our comments and let us know!</em></p>
<script data-cfasync="false" type="text/javascript">
var addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":300,"ignore_server_config":true};
var addthis_share = {"passthrough":{"twitter":{"via":"geekforever"}}};
</script>
                <!-- AddThis Settings Begin -->
                <script data-cfasync="false" type="text/javascript">
                    var addthis_product = "wpp-5.3.5";
                    var wp_product_version = "wpp-5.3.5";
                    var wp_blog_version = "4.7.4";
                    var addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"5.3.5","anonymous_profile_id":"wp-05693716ff6d9068c10caa888a1e37c7","plugin_mode":"WordPress","select_prefs":{"addthis_per_post_enabled":true,"addthis_above_enabled":true,"addthis_below_enabled":true,"addthis_sidebar_enabled":false,"addthis_mobile_toolbar_enabled":true,"addthis_above_showon_home":false,"addthis_above_showon_posts":true,"addthis_above_showon_pages":true,"addthis_above_showon_archives":false,"addthis_above_showon_categories":false,"addthis_above_showon_excerpts":false,"addthis_below_showon_home":false,"addthis_below_showon_posts":true,"addthis_below_showon_pages":true,"addthis_below_showon_archives":false,"addthis_below_showon_categories":false,"addthis_below_showon_excerpts":false,"addthis_sidebar_showon_home":true,"addthis_sidebar_showon_posts":true,"addthis_sidebar_showon_pages":true,"addthis_sidebar_showon_archives":true,"addthis_sidebar_showon_categories":true,"addthis_mobile_toolbar_showon_home":false,"addthis_mobile_toolbar_showon_posts":true,"addthis_mobile_toolbar_showon_pages":true,"addthis_mobile_toolbar_showon_archives":false,"addthis_mobile_toolbar_showon_categories":false,"sharing_enabled_on_post_via_metabox":true},"page_info":{"template":"posts","post_type":""}};
                    if (typeof(addthis_config) == "undefined") {
                        var addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":300,"ignore_server_config":true};
                    }
                    if (typeof(addthis_share) == "undefined") {
                        var addthis_share = {"passthrough":{"twitter":{"via":"geekforever"}}};
                    }
                    if (typeof(addthis_layers) == "undefined") {
                        var addthis_layers = {"sharedock":{"counts":false,"position":"bottom","numPreferredServices":4}};
                    }
                </script>
                <script
                    data-cfasync="false"
                    type="text/javascript"
                    src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b76011022e6a2e "
                    async="async"
                >
                </script>
                <script data-cfasync="false" type="text/javascript">
                    (function() {
                        var at_interval = setInterval(function () {
                            if(window.addthis) {
                                clearInterval(at_interval);
                                addthis.layers(addthis_layers);
                            }
                        },1000)
                    }());
                </script>
                <!-- AddThis Sharing Buttons below --><div class="addthis_toolbox addthis_default_style addthis_32x32_style" addthis:url='http://www.forevergeek.com/2017/04/indie-games-2017/' ><a class="addthis_button_facebook"></a><a class="addthis_button_twitter"></a><a class="addthis_button_pinterest_share"></a><a class="addthis_button_google_plusone_share"></a><a class="addthis_button_reddit"></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.forevergeek.com/2017/04/indie-games-2017/"
    dc:identifier="http://www.forevergeek.com/2017/04/indie-games-2017/"
    dc:title="5 Indie Games to Keep An Eye Out for in 2017"
    trackback:ping="http://www.forevergeek.com/2017/04/indie-games-2017/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><div class="after-entry" class="widget-area"><section id="text-31" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_responsive_sharing"></div>
</div>
		</div></section>
</div><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://www.forevergeek.com/category/games/" rel="category tag">Games</a></span> <span class="entry-tags">Tagged With: <a href="http://www.forevergeek.com/tag/indie-games/" rel="tag">indie games</a>, <a href="http://www.forevergeek.com/tag/video-games/" rel="tag">video games</a></span></p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="http://schema.org/Person"><img alt='' src='http://2.gravatar.com/avatar/8e83ee42a58a290c7e22cb73c1c38f4e?s=70&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/8e83ee42a58a290c7e22cb73c1c38f4e?s=140&amp;d=identicon&amp;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Remy Carreiro</span></h4><div class="author-box-content" itemprop="description"></div></section>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/indie-games-2017/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.forevergeek.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="cptch_block"><span class="cptch_title">Please prove you&#039;re human<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_92"><span class="cptch_span"><input id="cptch_input_92" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;&minus;&nbsp;</span>
					<span class="cptch_span">si&#120;</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">3</span>
					<input type="hidden" name="cptch_result" value="BYE=" /><input type="hidden" name="cptch_time" value="1492881947" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='75544' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e0522ca6a7" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="72"/></p>			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><div class='widget atf'><script src='http://www.googletagservices.com/tag/js/gpt.js'>googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_ATF', [300, 250]).display();</script></div><section id="text-37" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">
<a href="https://feeds.feedburner.com/ForeverGeek"><img src="http://www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png"></a>
</div>
		</div></section>
<section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="http://www.forevergeek.com/" role="search"><meta itemprop="target" content="http://www.forevergeek.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-36" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://www.forevergeek.com/2016/01/5-retro-video-games-that-are-still-fun-to-play/" target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/06/Old-school-video-games.jpg"></a>
<br>
<br>
<br>
<br>
<a href="http://www.forevergeek.com/2014/01/sonic-the-hedgehog-sexy-cosplay/"  target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/06/Sonic-the-Hedgehog-Sexy-Cosplay.jpg"></a>
<br>
<br>
<br>
<br>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FG 300x600 Large Skyscraper -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-6912717002762685"
     data-ad-slot="4438984693"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

<br>
<br>
<br>
<br>

<div id="zergnet-widget-14299"></div>

<script language="javascript" type="text/javascript">
	(function() {
		var zergnet = document.createElement('script');
		zergnet.type = 'text/javascript'; zergnet.async = true;
		zergnet.src = 'http://www.zergnet.com/zerg.js?id=14299';
		var znscr = document.getElementsByTagName('script')[0];
		znscr.parentNode.insertBefore(zergnet, znscr);
	})();
</script>
<br>
<br>
<br>
<br></div>
		</div></section>
<section id="text-35" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://www.forevergeek.com/2015/11/5-geeky-cutting-boards/" target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/05/Geeky-Cutting-Boards-1.jpg"></a>
<br>
<br></div>
		</div></section>
<section id="text-34" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://www.forevergeek.com/2016/01/why-kylo-ren-is-wildly-misunderstood-and-may-be-best-star-wars-villain-yet/"  target="_blank"><img src="http://www.forevergeek.com/wp-content/media/2016/05/Kylo-Ren-Best-Villain-1.jpg"></a></div>
		</div></section>
<div class='widget btf'><script src='http://www.googletagservices.com/tag/js/gpt.js'>googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_BTF', [300, 250]).display();</script></div></aside></div></div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><p>ForeverGeek &#x000A9;&nbsp;2017 Splashpress Media</p></div></footer></div>	<div style="display:none">
	<div class="grofile-hash-map-ce8c7efeca02917c1994ff9368f8ae5e">
	</div>
	</div>
<script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "fade",directionNav: ,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script><script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<link rel='stylesheet' id='addthis_output-css'  href='http://www.forevergeek.com/wp-content/plugins/addthis/css/output.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201716'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Apraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/comment-reply.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"e84dd1bd5e","ajaxurl":"http:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","enlarge":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.forevergeek.com/wp-content/plugins/captcha/js/front_end_script.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201716.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'11258759',post:'75544',tz:'-4',srv:'www.forevergeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '11258759', '75544' ]);
</script>
<!--wp_footer--></body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced
Fragment Caching 4/4 fragments using disk

 Served from: forevergeek.com @ 2017-04-22 13:25:47 by W3 Total Cache -->