<!DOCTYPE html><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-1&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-1&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-1&cb=5', false, [], true, false, true, false);</script><meta name="viewport" content="width=device-width, initial-scale=1"/><meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"/> <style id="aoatfcss" media="all">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</style><link rel="stylesheet" media="print" href="https://www.forevergeek.com/wp-content/cache/autoptimize/css/autoptimize_a1b14a804d9381b25c2c87730228928a.css" onload="this.onload=null;this.media=&#39;all&#39;;"/><noscript id="aonoscrcss"><link media="all" href="https://www.forevergeek.com/wp-content/cache/autoptimize/css/autoptimize_a1b14a804d9381b25c2c87730228928a.css" rel="stylesheet" /></noscript><title>20 Stocking Geeky Stuffers for 2021 | ForeverGeek</title><meta name="description" content="As the saying goes, big things come in small packages. So check out these awesome 20 stocking geeky stuffers for 2021!"/><link rel="canonical" href="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="20 Stocking Geeky Stuffers for 2021 | ForeverGeek"/><meta property="og:description" content="As the saying goes, big things come in small packages. So check out these awesome 20 stocking geeky stuffers for 2021!"/><meta property="og:url" content="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/"/><meta property="og:site_name" content="ForeverGeek"/><meta property="article:publisher" content="https://www.facebook.com/forevergeek.blog"/><meta property="article:published_time" content="2021-12-13T17:23:58+00:00"/><meta property="og:image" content="//www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg"/><meta property="og:image:width" content="700"/><meta property="og:image:height" content="449"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:creator" content="@geekforever"/><meta name="twitter:site" content="@geekforever"/><meta name="twitter:label1" content="Written by"/><meta name="twitter:data1" content="Bea"/><meta name="twitter:label2" content="Est. reading time"/><meta name="twitter:data2" content="8 minutes"/> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.forevergeek.com/#website","url":"https://www.forevergeek.com/","name":"ForeverGeek","description":"Nerds are for Dorks","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.forevergeek.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/#primaryimage","inLanguage":"en-US","url":"https://www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg","contentUrl":"https://www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg","width":700,"height":449,"caption":"CWMBRAN, WALES - DECEMBER 10: Christmas stockings are displayed in the showroom at the Festive Productions Ltd premises on December 10, 2013 in Cwmbran, Wales. Although Christmas Day 2013 is only two weeks away, the staff at Festive are already planning and gearing up for Christmas 2014. The 14 acre fully integrated showroom, factory and warehouse measuring 250000 sq ft in size holds Festive Productions, who are now the last manufacturer of tinsel in UK - with the majority of tinsel sold in the UK made at the factory in Wales. As well as tinsel, Festive, which is one of Europe's largest suppliers and manufacturer of Christmas and seasonal decorations, has increased its product portfolio, to include nearly every conceivable Christmas decoration category including baubles, tinsel garlands, wreaths, lights, fibre optic trees and artificial trees. (Photo by Matt Cardy/Getty Images)"},{"@type":"WebPage","@id":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/#webpage","url":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/","name":"20 Stocking Geeky Stuffers for 2021 | ForeverGeek","isPartOf":{"@id":"https://www.forevergeek.com/#website"},"primaryImageOfPage":{"@id":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/#primaryimage"},"datePublished":"2021-12-13T17:23:58+00:00","dateModified":"2021-12-13T17:23:58+00:00","author":{"@id":"https://www.forevergeek.com/#/schema/person/7d0774c4051d70c1951a8f35058bcb04"},"description":"As the saying goes, big things come in small packages. So check out these awesome 20 stocking geeky stuffers for 2021!","breadcrumb":{"@id":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/"]}]},{"@type":"BreadcrumbList","@id":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.forevergeek.com/"},{"@type":"ListItem","position":2,"name":"20 Geeky Stocking Stuffers for 2021"}]},{"@type":"Person","@id":"https://www.forevergeek.com/#/schema/person/7d0774c4051d70c1951a8f35058bcb04","name":"Bea","image":{"@type":"ImageObject","@id":"https://www.forevergeek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/3be82375f5717e76a687dbdd4c72e63f?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/3be82375f5717e76a687dbdd4c72e63f?s=96&d=identicon&r=g","caption":"Bea"},"url":"https://www.forevergeek.com/author/bea/"}]}</script> <link rel="dns-prefetch" href="//v0.wordpress.com"/><link rel="alternate" type="application/rss+xml" title="ForeverGeek » Feed" href="https://www.forevergeek.com/feed/"/><link rel="alternate" type="application/rss+xml" title="ForeverGeek » Comments Feed" href="https://www.forevergeek.com/comments/feed/"/><link rel="alternate" type="application/rss+xml" title="ForeverGeek » 20 Geeky Stocking Stuffers for 2021 Comments Feed" href="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/feed/"/> <script type="text/javascript" id="jetpack_related-posts-js-extra">var related_posts_js_options = {"post_heading":"h4"};</script> <link rel="https://api.w.org/" href="https://www.forevergeek.com/wp-json/"/><link rel="alternate" type="application/json" href="https://www.forevergeek.com/wp-json/wp/v2/posts/90283"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.forevergeek.com/xmlrpc.php?rsd"/><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.forevergeek.com/wp-includes/wlwmanifest.xml"/><link rel="shortlink" href="https://wp.me/pLeUT-nub"/><link rel="alternate" type="application/json+oembed" href="https://www.forevergeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forevergeek.com%2F20-geeky-stocking-stuffers-for-2021%2F"/><link rel="alternate" type="text/xml+oembed" href="https://www.forevergeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forevergeek.com%2F20-geeky-stocking-stuffers-for-2021%2F&amp;format=xml"/> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.forevergeek.com/?wordfence_lh=1&hid=5715650FF2C46B7F9F9C07AD65169B07');</script> <link rel="icon" href="https://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/favicon.png"/><link rel="pingback" href="https://www.forevergeek.com/xmlrpc.php"/><meta name="google-site-verification" content="oV-Ua2VGHAYSk8L0RfBgjNLNotbED-4qeoERwVuI1os"/> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6912717002762685" crossorigin="anonymous"></script><script type="text/javascript">var ezouid = "1";</script><base href="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 212238;
var ezdomain = 'forevergeek.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":212238,"domain_test_group":20210309,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"49f138b3-2ec9-4cc1-6e42-ccb0db44c86b","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":91397,"response_time_orig":468,"serverid":"52.87.186.57:26417","state":"VA","t_epoch":1639455872,"template_id":126,"time_on_site_visit":0,"url":"https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/","user_id":0,"word_count":1046,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_212238=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["49f138b3-2ec9-4cc1-6e42-ccb0db44c86b", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-90283 single-format-standard desktop content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-visible"><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.forevergeek.com" title="ForeverGeek"><img class="site-logo" src="https://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/logo.png?v=2" alt="ForeverGeek logo"/></a></p></div><div class="widget-area header-widget-area"><section id="custom_html-13" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-126"></div></div></div></section></div></div></header><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-header-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-64951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64951"><a href="https://www.forevergeek.com/category/features/"><span>Features</span></a></li><li id="menu-item-64952" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64952"><a href="https://www.forevergeek.com/category/cool-stuff-geekery/"><span>Cool Stuff &amp; Geekery</span></a></li><li id="menu-item-64953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64953"><a href="https://www.forevergeek.com/category/movies-television/"><span>Movies &amp; TV</span></a></li><li id="menu-item-64954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64954"><a href="https://www.forevergeek.com/category/anime-comics/"><span>Anime &amp; Comics</span></a></li><li id="menu-item-66222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66222"><a href="https://www.forevergeek.com/category/games/"><span>Games</span></a></li><li id="menu-item-64955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64955"><a href="#"><span>More!</span></a><ul class="sub-menu"><li id="menu-item-64960" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64960"><a href="https://www.forevergeek.com/category/general/"><span>General</span></a></li><li id="menu-item-64958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64958"><a href="https://www.forevergeek.com/about/"><span>About ForeverGeek</span></a></li><li id="menu-item-64959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64959"><a href="https://www.forevergeek.com/contact/"><span>Contact</span></a></li><li id="menu-item-84855" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84855"><a href="https://www.forevergeek.com/affiliate-referral-links/"><span>Affiliate &amp; Referral Links</span></a></li><li id="menu-item-64956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64956"><a href="https://www.forevergeek.com/terms-privacy/"><span>Terms &amp; Privacy</span></a></li></ul></li><li class="right social"><a href="https://www.pinterest.com/forevergeek/"><span class="genericon genericon-pinterest"></span></a></li><li class="right social"><a href="https://twitter.com/geekforever"><span class="genericon genericon-twitter"></span></a></li><li class="right social"><a href="https://www.facebook.com/forevergeek.blog"><span class="genericon genericon-facebook-alt"></span></a></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-90283 post type-post status-publish format-standard has-post-thumbnail category-cool-stuff-geekery tag-christmas tag-dept-of-want-it tag-gifts tag-stocking-stuffers entry" aria-label="20 Geeky Stocking Stuffers for 2021"><header class="entry-header"><h1 class="entry-title">20 Geeky Stocking Stuffers for 2021</h1><p class="entry-meta"><time class="entry-time">December 13, 2021</time> by <span class="entry-author"><a href="https://www.forevergeek.com/author/bea/" class="entry-author-link" rel="author"><span class="entry-author-name">Bea</span></a></span> <span class="entry-comments-link"><a href="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/#respond">Leave a Comment</a></span></p></header><div class="entry-content"><p><img width="700" height="449" src="https://www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg" class="attachment-large size-large wp-post-image" alt="Geeky Stocking Stuffers" loading="lazy" data-attachment-id="90309" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/festive-productions-prepares-for-christmas-2014/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg" data-orig-size="700,449" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;Getty Images&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;CWMBRAN, WALES - DECEMBER 10:  Christmas stockings are displayed in the showroom at the Festive Productions Ltd premises on December 10, 2013 in Cwmbran, Wales. Although Christmas Day 2013 is only two weeks away, the staff at Festive are already planning and gearing up for Christmas 2014. The 14 acre fully integrated showroom, factory and warehouse measuring 250000 sq ft in size holds Festive Productions, who are now the last manufacturer of tinsel in UK - with the majority of tinsel sold in the UK made at the factory in Wales. As well as tinsel, Festive, which is one of Europe&#39;s largest suppliers and manufacturer of Christmas and seasonal decorations, has increased its product portfolio, to include nearly every conceivable Christmas decoration category including baubles, tinsel garlands, wreaths, lights, fibre optic trees and artificial trees.  (Photo by Matt Cardy\/Getty Images)&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;2013 Getty Images&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;Festive Productions Prepares For Christmas 2014&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="Festive Productions Prepares For Christmas 2014" data-image-description="" data-image-caption="&lt;p&gt;CWMBRAN, WALES – DECEMBER 10:  Christmas stockings are displayed in the showroom at the Festive Productions Ltd premises on December 10, 2013 in Cwmbran, Wales. Although Christmas Day 2013 is only two weeks away, the staff at Festive are already planning and gearing up for Christmas 2014. The 14 acre fully integrated showroom, factory and warehouse measuring 250000 sq ft in size holds Festive Productions, who are now the last manufacturer of tinsel in UK – with the majority of tinsel sold in the UK made at the factory in Wales. As well as tinsel, Festive, which is one of Europe’s largest suppliers and manufacturer of Christmas and seasonal decorations, has increased its product portfolio, to include nearly every conceivable Christmas decoration category including baubles, tinsel garlands, wreaths, lights, fibre optic trees and artificial trees.  (Photo by Matt Cardy/Getty Images)&lt;/p&gt;
" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/image-e1639186941562.jpg"/></p><div class="before-entry" class="widget-area"><section id="text-40" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="ezoic-pub-ad-placeholder-132"> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6912717002762685" data-ad-slot="3496802290"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></section></div><div class="at-above-post addthis_tool" data-url="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/"></div><p>As the saying goes, big things come in small packages. THAT is exactly what you need to remember when picking out great stocking stuffers for your geeky friends and loved ones this Christmas. They’re small, random, relatively inexpensive gifts, but they definitely let people know you’ve thought about them. When it comes to spreading holiday cheer, they simply get the job done. So check out these awesome 20 stocking geeky stuffers for 2021!</p><p><span id="more-90283"></span></p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Ftoys%2Fproducts%2Fminecraft-blind-boxed-character-slime-one-random" target="_blank" rel="noopener">Minecraft Blind Boxed Character Slime</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Ftoys%2Fproducts%2Fminecraft-blind-boxed-character-slime-one-random "><img data-attachment-id="90289" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/jtt-85922-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/JTT-85922-CA_2048x-e1639028943239.jpg" data-orig-size="400,435" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="JTT-85922-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/JTT-85922-CA_2048x-e1639028943239.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/JTT-85922-CA_2048x-e1639028943239.jpg" loading="lazy" class="aligncenter wp-image-90289 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/JTT-85922-CA_2048x-e1639028943239.jpg" alt="Minecraft" width="400" height="435"/></a></p><p>Have a squishy, fun time playing with this Minecraft cube filled with slime and one of seven different character figures! Have it for yourself or give it to the Minecraft fan in your life!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fharry-potter-chibi-castle-6-inch-light-up-snow-globe" target="_blank" rel="noopener">Harry Potter Chibi Castle 6 Inch Light Up Snow Globe</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fharry-potter-chibi-castle-6-inch-light-up-snow-globe "><img data-attachment-id="90294" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/svb-hp1473j9-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/SVB-HP1473J9-CA_2048x-e1639029624542.jpg" data-orig-size="300,415" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="SVB-HP1473J9-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/SVB-HP1473J9-CA_2048x-e1639029624542.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/SVB-HP1473J9-CA_2048x-e1639029624542.jpg" loading="lazy" class="aligncenter wp-image-90294 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/SVB-HP1473J9-CA_2048x-e1639029624542.jpg" alt="HP Globe" width="300" height="415"/></a></p><p>What’s Christmas without a little magic? This Harry Potter Snow Globe is the perfect gift to any Potterhead who’s impatiently waiting for the cast’s <a href="https://news.yahoo.com/everything-know-harry-potter-reunion-202703831.html" target="_blank" rel="noopener">reunion on HBO Max</a> coming this January 2022!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fproducts%2Fback-to-the-future-flux-capacitor-replica-usb-mood-light-6-inches-tall" target="_blank" rel="noopener">Back to the Future Flux Capacitor Replica USB Mood Light</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fproducts%2Fback-to-the-future-flux-capacitor-replica-usb-mood-light-6-inches-tall "><img data-attachment-id="90286" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/rbf-16540-cb_800x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/RBF-16540-CB_800x-e1639028433219.jpg" data-orig-size="500,413" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="RBF-16540-CB_800x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/RBF-16540-CB_800x-e1639028433219.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/RBF-16540-CB_800x-e1639028433219.jpg" loading="lazy" class="aligncenter wp-image-90286 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/RBF-16540-CB_800x-e1639028433219.jpg" alt="Back to the Future Flux Capacitor Replica USB Mood Light" width="500" height="413"/></a></p><p>Light up someone’s mood with this mini Flux Capacitor USB Mood Light. Inspired by the 80s classic, this tiny gadget here can be used as a night light or a really cool collectible!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fproducts%2Fmarvel-studios-loki-miss-minutes-exclusive-mechanical-kitchen-timer-for-cooking-countdown-timer-with-loud-alarm-home-kitchen-gadget-essentials-counter-decor-superhero-comic-book-gifts-and-collectibles" target="_blank" rel="noopener">Marvel Studios Loki Miss Minutes Mechanical Kitchen Timer</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fproducts%2Fmarvel-studios-loki-miss-minutes-exclusive-mechanical-kitchen-timer-for-cooking-countdown-timer-with-loud-alarm-home-kitchen-gadget-essentials-counter-decor-superhero-comic-book-gifts-and-collectibles "><img data-attachment-id="90288" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/sre-egtm-lki-miss-cd_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/SRE-EGTM-LKI-MISS-CD_2048x-e1639028809724.jpg" data-orig-size="500,413" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="SRE-EGTM-LKI-MISS-CD_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/SRE-EGTM-LKI-MISS-CD_2048x-e1639028809724.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/SRE-EGTM-LKI-MISS-CD_2048x-e1639028809724.jpg" loading="lazy" class="aligncenter wp-image-90288 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/SRE-EGTM-LKI-MISS-CD_2048x-e1639028809724.jpg" alt="Loki Miss Minutes Timer" width="500" height="413"/></a></p><p>It’s finally time to get your hands on this *exclusive* Loki-inspired Miss Minutes kitchen timer. Give this one to a loved one to help them *count down* to New Year! Am I right?</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fdj-organic-mega-ran-coin-op-crush-music-cd-arcade-block-exclusive%2369386666003-1" target="_blank" rel="noopener">DJ Organic Mega Ran Coin Op Crush Music CD</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fdj-organic-mega-ran-coin-op-crush-music-cd-arcade-block-exclusive%2369386666003-1"><img data-attachment-id="90290" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/nbk-djorgcn-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/NBK-DJORGCN-CA_2048x-e1639029210224.jpg" data-orig-size="500,453" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="NBK-DJORGCN-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/NBK-DJORGCN-CA_2048x-e1639029210224.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/NBK-DJORGCN-CA_2048x-e1639029210224.jpg" loading="lazy" class="aligncenter wp-image-90290 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/NBK-DJORGCN-CA_2048x-e1639029210224.jpg" alt="Arcade Music" width="500" height="453"/></a></p><p>Dance to the beat of your favorite arcade games with this one-of-a-kind CD featuring some cool video game-influenced tunes!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/1016511757/oil-painting-puzzle-rubiks-cube-van-gogh?click_key=799749a61426d6249555b2552a9b7eefdd328657%3A1016511757&amp;click_sum=2871b413&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=rubiks+cube&amp;ref=sr_gallery-1-19&amp;organic_search_click=1" target="_blank" rel="noopener">Oil Painting Puzzle Rubik’s Cube</a></h2><p><img data-attachment-id="90307" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-3527201306_9j9o/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3527201306_9j9o-e1639186395655.jpg" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.3527201306_9j9o" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3527201306_9j9o-e1639186395655.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3527201306_9j9o-e1639186395655.jpg" loading="lazy" class="size-full wp-image-90307 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.3527201306_9j9o-e1639186395655.jpg" alt="Painting Rubiks" width="400" height="400"/></p><p>If you think Rubik’s cubes were for nerds, you’re in for a surprise with this oil painting puzzle Rubik’s cube! Gift this to an art lover, a puzzle genius, or both!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Falien%2Fproducts%2Falien-4-madballs-horrorballs-facehugger" target="_blank" rel="noopener">Alien 4″ Madballs Horrorballs</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Falien%2Fproducts%2Falien-4-madballs-horrorballs-facehugger	"><img data-attachment-id="90295" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/krb-tblcg201-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/KRB-TBLCG201-CA_2048x-e1639029826824.jpg" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="KRB-TBLCG201-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/KRB-TBLCG201-CA_2048x-e1639029826824.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/KRB-TBLCG201-CA_2048x-e1639029826824.jpg" loading="lazy" class="aligncenter wp-image-90295 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/KRB-TBLCG201-CA_2048x-e1639029826824.jpg" alt="Alien" width="400" height="400"/></a></p><p>Anyone familiar with Horrorballs! Kidrobot, Madballs, and more know-how freakishly fun it is to collect them all! These monstrous mashups feature some of our favorite villains from Aliens, Predator, Friday the 13th, A Nightmare On Elm Street, and more!</p><h2 class="product__information has-product-sticker one-half column medium-down--one-whole"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fdoctor-who-dalek-and-cyberman-talking-pen" target="_blank" rel="noopener">Doctor Who Dalek and Cyberman Talking Pen</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fdoctor-who-dalek-and-cyberman-talking-pen	"><img data-attachment-id="90292" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/ugt-dr117-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/UGT-DR117-CA_2048x-e1639029424122.jpg" data-orig-size="300,594" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="UGT-DR117-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/UGT-DR117-CA_2048x-e1639029424122.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/UGT-DR117-CA_2048x-e1639029424122.jpg" loading="lazy" class="aligncenter wp-image-90292 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/UGT-DR117-CA_2048x-e1639029424122.jpg" alt="Dr. Who Pen" width="300" height="594"/></a></p><p>Hear some of the Doctor’s worst and monstrous enemies, The Daleks and Cybermen! This officially licensed Doctor Who collectible features 3 different sounds that are bound to creep out fans.</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fharry-potter-gringotts-9-inch-ceramic-coin-bank" target="_blank" rel="noopener">Harry Potter Gringotts 9-Inch Ceramic Coin Bank</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fhome-office%2Fproducts%2Fharry-potter-gringotts-9-inch-ceramic-coin-bank	"><img data-attachment-id="90293" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/fab-73425-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/FAB-73425-CA_2048x-e1639029548628.jpg" data-orig-size="350,350" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="FAB-73425-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/FAB-73425-CA_2048x-e1639029548628.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/FAB-73425-CA_2048x-e1639029548628.jpg" loading="lazy" class="aligncenter wp-image-90293 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/FAB-73425-CA_2048x-e1639029548628.jpg" alt="Gringots" width="350" height="350"/></a></p><p>Just like the building this ceramic was inspired by, you can stash your cash (and gold!) in them. If you’ve always wanted to visit Gringotts Wizarding Bank, now is your chance!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fbig-bang-theory%2Fproducts%2Fbig-bang-theory-bazinga-cape-socks-grey" target="_blank" rel="noopener">Big Bang Theory Bazinga Cape Socks</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fbig-bang-theory%2Fproducts%2Fbig-bang-theory-bazinga-cape-socks-grey	"><img data-attachment-id="90296" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/rpj_btsk2405_ca_b802eda2-3c3a-40e8-89b8-47c14a72d3ea_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/RPJ_BTSK2405_CA_b802eda2-3c3a-40e8-89b8-47c14a72d3ea_2048x.jpg" data-orig-size="400,600" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="RPJ_BTSK2405_CA_b802eda2-3c3a-40e8-89b8-47c14a72d3ea_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/RPJ_BTSK2405_CA_b802eda2-3c3a-40e8-89b8-47c14a72d3ea_2048x.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/RPJ_BTSK2405_CA_b802eda2-3c3a-40e8-89b8-47c14a72d3ea_2048x.jpg" loading="lazy" class="aligncenter wp-image-90296" src="//forevergeek.com/wp-content/media/2021/12/RPJ_BTSK2405_CA_b802eda2-3c3a-40e8-89b8-47c14a72d3ea_2048x.jpg" alt="Bazinga" width="300" height="450"/></a></p><p>Big Bang Theory fans will go ga-ga over these Sheldon-inspired socks. Talk about ironic stocking stuffers!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fbattlestar-galactica%2Fproducts%2Fbattlestar-galactica-one-shot-comic-comic-block-exclusive-cover" target="_blank" rel="noopener">Battlestar Galactica One-Shot Comic (Comic Block Exclusive Cover)</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fbattlestar-galactica%2Fproducts%2Fbattlestar-galactica-one-shot-comic-comic-block-exclusive-cover	"><img data-attachment-id="90297" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/nbk-25043-ca_4563c6f6-ab6a-4649-b0d8-acd7e717c9dd_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/NBK-25043-CA_4563c6f6-ab6a-4649-b0d8-acd7e717c9dd_2048x-e1639030192424.jpg" data-orig-size="300,440" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="NBK-25043-CA_4563c6f6-ab6a-4649-b0d8-acd7e717c9dd_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/NBK-25043-CA_4563c6f6-ab6a-4649-b0d8-acd7e717c9dd_2048x-e1639030192424.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/NBK-25043-CA_4563c6f6-ab6a-4649-b0d8-acd7e717c9dd_2048x-e1639030192424.jpg" loading="lazy" class="aligncenter wp-image-90297 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/NBK-25043-CA_4563c6f6-ab6a-4649-b0d8-acd7e717c9dd_2048x-e1639030192424.jpg" alt="Battlestar" width="300" height="440"/></a></p><p>Does this comic book pique your interest? Well, you have to get it and read it to find out how the crew gets out of trouble this time!</p><h2 class="product_name title is-hidden-mobile-only"><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fchilds-play%2Fproducts%2Fchilds-play-chucky-playing-cards-52-card-deck-2-jokers" target="_blank" rel="noopener">Child’s Play Chucky Playing Cards</a></h2><p><a href="https://click.linksynergy.com/deeplink?id=4KF6s61wTQ4&amp;mid=45081&amp;murl=https%3A%2F%2Fwww.toynk.com%2Fcollections%2Fchilds-play%2Fproducts%2Fchilds-play-chucky-playing-cards-52-card-deck-2-jokers	"><img data-attachment-id="90298" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/nmr-52740-ca_2048x/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/NMR-52740-CA_2048x-e1639030281654.jpg" data-orig-size="500,431" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="NMR-52740-CA_2048x" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/NMR-52740-CA_2048x-e1639030281654.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/NMR-52740-CA_2048x-e1639030281654.jpg" loading="lazy" class="aligncenter wp-image-90298 size-full" src="//www.forevergeek.com/wp-content/media/2021/12/NMR-52740-CA_2048x-e1639030281654.jpg" alt="chucky cards" width="500" height="431"/></a></p><p>Think this deck of Child’s Play Chucky cards is harmless? Think again. Escape death and let the terror begin!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/1116347216/the-stars-and-wars-pencil-set-unique-fun?click_key=a9ebc22002191f5410f2ce581b4b3727ffc10c7b%3A1116347216&amp;click_sum=c5b95cb4&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=geeky+stocking+stuffer&amp;ref=sr_gallery-1-38&amp;organic_search_click=1" target="_blank" rel="noopener">Star Wars Pencil Set</a></h2><p><img data-attachment-id="90300" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-3501958832_3nv7/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3501958832_3nv7-e1639184191236.jpg" data-orig-size="350,350" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.3501958832_3nv7" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3501958832_3nv7-e1639184191236.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3501958832_3nv7-e1639184191236.jpg" loading="lazy" class="size-full wp-image-90300 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.3501958832_3nv7-e1639184191236.jpg" alt="Star Wars Pencils" width="350" height="350"/></p><p>Check out this adorkable Star Wars pencil set, featuring some of the franchise’s most famous quotes. It’s the perfect thing to have when answering a test or writing a story of your own, isn’t it?</p><h2><a href="https://www.etsy.com/listing/563250492/d20-dice-case-storage-container-w?click_key=01700a4f6aa3bec1fed9fccbf9e66d648ebca70b%3A563250492&amp;click_sum=3323e03d&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=geeky+stocking+stuffer&amp;ref=sr_gallery-1-42&amp;organic_search_click=1" target="_blank" rel="noopener">DND D20 Dice Storage w/ Magnetized Lid</a></h2><p><img data-attachment-id="90301" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_794xn-1419563749_o8v7/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_794xN.1419563749_o8v7-e1639184287173.jpg" data-orig-size="650,488" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_794xN.1419563749_o8v7" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_794xN.1419563749_o8v7-e1639184287173.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_794xN.1419563749_o8v7-e1639184287173.jpg" loading="lazy" class="size-full wp-image-90301 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_794xN.1419563749_o8v7-e1639184287173.jpg" alt="DND Dice Storage" width="650" height="488"/></p><p>Gift this 3D-printed D20 dice container to D&amp;D or Pathfinder gaming group friends. They can use it to store their dice or even their valuables.</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/508985518/surprise-t-shirt-ah-the-element-of?ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=geeky+small+gifts&amp;ref=sc_gallery-1-1&amp;listing_id=508985518&amp;listing_slug=surprise-t-shirt-ah-the-element-of&amp;plkey=1feeddec75ac02160b6ca911d9c708df7cd2ee00%3A508985518" target="_blank" rel="noopener">Ah! The Element of Surprise T-Shirt</a></h2><p><img data-attachment-id="90302" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-1171996230_d8en/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.1171996230_d8en-e1639184617734.jpg" data-orig-size="400,401" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.1171996230_d8en" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.1171996230_d8en-e1639184617734.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.1171996230_d8en-e1639184617734.jpg" loading="lazy" class="size-full wp-image-90302 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.1171996230_d8en-e1639184617734.jpg" alt="Ah! The Element of Surprise Shirt" width="400" height="401"/></p><p>This funny and witty shirt is great for nerds who love a bit of wordplay and chemistry fun! It’s definitely right up my alley!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/930737873/custom-made-large-gelatinous-cube-w?click_key=9172887a779518961d6f602b8f63f44353eac801%3A930737873&amp;click_sum=969a8147&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=geeky+stocking+stuffer&amp;ref=sr_gallery-3-8&amp;organic_search_click=1" target="_blank" rel="noopener">CUSTOM MADE Large Gelatinous Cube w/ DND Miniature Inside</a></h2><p><img data-attachment-id="90303" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-2752317344_1zzq/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.2752317344_1zzq-e1639184728871.jpg" data-orig-size="650,365" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.2752317344_1zzq" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.2752317344_1zzq-e1639184728871.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.2752317344_1zzq-e1639184728871.jpg" loading="lazy" class="size-full wp-image-90303 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.2752317344_1zzq-e1639184728871.jpg" alt="DND Miniature Toy" width="650" height="365"/></p><p>This one may appear a bit odd to those who don’t know there’s something inside. Just make sure to put it in the card!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/757483300/anime-mug-introverted-but-willing-to?click_key=3a49cef4945a44aefc4b43c1f5b3c461fcfdca16%3A757483300&amp;click_sum=37124463&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=anime+gifts&amp;ref=sr_gallery-3-21&amp;organic_search_click=1" target="_blank" rel="noopener">Introverted But Willing To Discuss Anime Mug</a></h2><p><img data-attachment-id="90304" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_794xn-2204282493_nee2/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_794xN.2204282493_nee2-e1639185253925.jpg" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_794xN.2204282493_nee2" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_794xN.2204282493_nee2-e1639185253925.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_794xN.2204282493_nee2-e1639185253925.jpg" loading="lazy" class="size-full wp-image-90304 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_794xN.2204282493_nee2-e1639185253925.jpg" alt="Anime Mug" width="400" height="400"/></p><p>Introverted, anime-loving geeks, this one’s for you! Take this as a sign that you were not forgotten!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/1121707770/brooklyn-99-colouring-book-tv-show?click_key=cfb90edc8d74295b81dc56e6deb7ed4dca9c3d70%3A1121707770&amp;click_sum=083b893d&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=tv+show+gifts&amp;ref=sr_gallery-2-13&amp;organic_search_click=1&amp;cns=1" target="_blank" rel="noopener">Brooklyn 99 Colouring Book</a></h2><p><img data-attachment-id="90305" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-3567151819_p1oo/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3567151819_p1oo-e1639185676328.jpg" data-orig-size="650,520" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.3567151819_p1oo" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3567151819_p1oo-e1639185676328.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3567151819_p1oo-e1639185676328.jpg" loading="lazy" class="size-full wp-image-90305 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.3567151819_p1oo-e1639185676328.jpg" alt="B99 Coloring Book" width="650" height="520"/></p><p>Get to know the precinct on a whole other level with this cool Brooklyn Nine Nine coloring book! It features 22 hand-drawn, cartoon-style pages that will make you want to binge-watch the show in the holidays!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/1101605257/tardis-dr-who-transparent-blue-milk?click_key=36862ecdb6f083442feb7002bc75e572e6451ceb%3A1101605257&amp;click_sum=640b5e45&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=dr+who+gifts&amp;ref=sr_gallery-1-40&amp;organic_search_click=1&amp;cns=1" target="_blank" rel="noopener">Tardis Dr. Who Transparent Blue Milk Carton Water Bottle</a></h2><p><img data-attachment-id="90306" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-3442193897_84m5/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3442193897_84m5-e1639185984721.jpg" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.3442193897_84m5" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3442193897_84m5-e1639185984721.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3442193897_84m5-e1639185984721.jpg" loading="lazy" class="size-full wp-image-90306 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.3442193897_84m5-e1639185984721.jpg" alt="Dr. Who Bottle" width="400" height="400"/></p><p>We’ve seen a lot of Doctor Who Tardis-inspired merch, but this one I was surprised to see. It’s also really practical. So show your Dr. Who-loving friends that you care about them staying hydrated!</p><h2 class="wt-text-body-03 wt-line-height-tight wt-break-word" data-buy-box-listing-title="true"><a href="https://www.etsy.com/listing/1123267753/jason-set-of-6-horror-minifigures-movie?click_key=777f4074bffd9891a99a4393ae6ac1ee6f028bb8%3A1123267753&amp;click_sum=f36a9c66&amp;ga_order=most_relevant&amp;ga_search_type=all&amp;ga_view_type=gallery&amp;ga_search_query=lego+toy&amp;ref=sr_gallery-1-4&amp;organic_search_click=1&amp;pop=1" target="_blank" rel="noopener">Movie Monsters Horror Minifigures</a></h2><p><img data-attachment-id="90308" data-permalink="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/il_1140xn-3476090200_efvd/" data-orig-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3476090200_efvd.jpg" data-orig-size="1140,906" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="il_1140xN.3476090200_efvd" data-image-description="" data-image-caption="" data-medium-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3476090200_efvd.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2021/12/il_1140xN.3476090200_efvd.jpg" loading="lazy" class="wp-image-90308 aligncenter" src="//forevergeek.com/wp-content/media/2021/12/il_1140xN.3476090200_efvd.jpg" alt="Horror Movies Minifigures" width="600" height="477"/></p><p>Satisfy your love for slasher/horror films with these *horrifying* collectibles. It has every iconic villain you can possibly think of — Penny-Wise, Jason Vorhees, Dracula, Godzilla, The Nun Valek, and so many more interesting characters!</p><h3><a href="https://forevergeek.com/watch-die-hard-instead-of-its-a-wonderful-life-as-your-christmas-movie/" target="_blank" rel="noopener">Why You Might Want To Watch Die Hard Instead of It’s a Wonderful Life As Your Christmas Movie</a></h3><h3><a href="https://forevergeek.com/how-real-geeks-celebrate-the-12-days-of-christmas/" target="_blank" rel="noopener">How Real Geeks Celebrate the 12 Days of Christmas</a></h3><div class="at-below-post addthis_tool" data-url="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-90283" class="share-twitter sd-button share-icon no-text" href="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-90283" class="share-facebook sd-button share-icon no-text" href="https://www.forevergeek.com/20-geeky-stocking-stuffers-for-2021/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div id="jp-relatedposts" class="jp-relatedposts"><h3 class="jp-relatedposts-headline"><em>Related</em></h3></div></div><footer class="entry-footer"><div class="after-entry" class="widget-area"><section id="text-31" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div class="addthis_responsive_sharing"></div></div></div></section><section id="custom_html-5" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-105"></div></div></div></section></div><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.forevergeek.com/category/cool-stuff-geekery/" rel="category tag">Cool Stuff &amp; Geekery</a></span> <span class="entry-tags">Tagged With: <a href="https://www.forevergeek.com/tag/christmas/" rel="tag">christmas</a>, <a href="https://www.forevergeek.com/tag/dept-of-want-it/" rel="tag">Dept. of Want It!</a>, <a href="https://www.forevergeek.com/tag/gifts/" rel="tag">Gifts</a>, <a href="https://www.forevergeek.com/tag/stocking-stuffers/" rel="tag">stocking stuffers</a></span></p></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/20-geeky-stocking-stuffers-for-2021/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.forevergeek.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate=""><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required"/></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required"/></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200"/></p><p class="cptch_block"><span class="cptch_title">Please prove you&#39;re human<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions"> <label class="cptch_label" for="cptch_input_50"><span class="cptch_span">5</span> <span class="cptch_span"> + </span> <span class="cptch_span">two</span> <span class="cptch_span"> = </span> <span class="cptch_span"><input id="cptch_input_50" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;"/></span> <input type="hidden" name="cptch_result" value="ZKw="/><input type="hidden" name="cptch_time" value="1639455873"/> <input type="hidden" name="cptch_form" value="wp_comments"/> </label><span class="cptch_reload_button_wrap hide-if-no-js"> <noscript><style type="text/css">.hide-if-no-js {
								display: none !important;
							}</style></noscript> <span class="cptch_reload_button dashicons dashicons-update"></span> </span></span></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"/> <input type="hidden" name="comment_post_ID" value="90283" id="comment_post_ID"/> <input type="hidden" name="comment_parent" id="comment_parent" value="0"/></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0c1a95b6d3"/></p><p style="display: none !important;"><label>Δ<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="29"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><div class="widget atf"><script src="//www.googletagservices.com/tag/js/gpt.js">googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_ATF', [300, 250]).display();</script></div><section id="custom_html-12" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-122"> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display: block;" data-ad-format="autorelaxed" data-ad-client="ca-pub-6912717002762685" data-ad-slot="2377344693"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></section><section id="search-2" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.forevergeek.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"/><input class="search-form-submit" type="submit" value="Search"/><meta content="https://www.forevergeek.com/?s={s}"/></form></div></section><section id="custom_html-17" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget">Some of the links in our posts are affiliate links. That means we may earn a small amount when you make a purchase when clicking our links – at no extra cost to you. This helps us to carry on dishing up geeky stuff. Thank you!</div></div></section><section id="text-37" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"> <a href="https://feeds.feedburner.com/ForeverGeek"><img src="https://www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png"/></a></div></div></section><section id="custom_html-8" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-125"></div></div></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-101"></div></div></div></section><section id="top-posts-2" class="widget widget_top-posts"><div class="widget-wrap"><h4 class="widget-title widgettitle">Top Posts &amp; Pages</h4><ul><li> <a href="https://www.forevergeek.com/15-anime-characters-who-struggle-with-mental-illness/" class="bump-view" data-bump-view="tp">15 Anime Characters Who Struggle With Mental Illness</a></li><li> <a href="https://www.forevergeek.com/6-adult-board-games-for-couples/" class="bump-view" data-bump-view="tp">10 Adult Board Games for Couples</a></li><li> <a href="https://www.forevergeek.com/8-essential-things-you-need-for-perfect-gaming-setup/" class="bump-view" data-bump-view="tp">8 Essential Things You Need For Perfect Gaming Setup</a></li><li> <a href="https://www.forevergeek.com/10-best-board-games-for-adults/" class="bump-view" data-bump-view="tp">10 Best Board Games For Adults</a></li><li> <a href="https://www.forevergeek.com/valuable-old-toys/" class="bump-view" data-bump-view="tp">The 25 Most Valuable Old Toys (You May Still Have!)</a></li></ul></div></section><section id="custom_html-18" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-6912717002762685" data-ad-slot="1382959817"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></section><section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-103"></div></div></div></section><section id="text-35" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="ezoic-pub-ad-placeholder-116"></div></div></div></section><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-102"></div></div></div></section><div class="widget btf"><script src="//www.googletagservices.com/tag/js/gpt.js">googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_BTF', [300, 250]).display();</script></div></aside></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="ezoic-pub-ad-placeholder-117"></div></div></div></section></div></div></div><footer class="site-footer"><div class="wrap"><p>ForeverGeek © 2021 Splashpress Media</p></div></footer></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-4829570-3', 'auto');
  ga('send', 'pageview');</script> <script type="text/javascript">var infolinks_pid = 3294769;
var infolinks_wsid = 34;</script> <script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script> <div id="jp-carousel-loading-overlay"><div id="jp-carousel-loading-wrapper"> <span id="jp-carousel-library-loading"> </span></div></div><div class="jp-carousel-overlay" style="display: none;"><div class="jp-carousel-container"><div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope="" itemtype="https://schema.org/ImageGallery"><div class="jp-carousel swiper-wrapper"></div><div class="jp-swiper-button-prev swiper-button-prev"> <svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"> <mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12"> <path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"></path> </mask> <g mask="url(#maskPrev)"> <rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"></rect> </g> </svg></div><div class="jp-swiper-button-next swiper-button-next"> <svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"> <mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12"> <path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"></path> </mask> <g mask="url(#maskNext)"> <rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"></rect> </g> </svg></div></div><div class="jp-carousel-close-hint"> <svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"> <mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14"> <path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"></path> </mask> <g mask="url(#maskClose)"> <rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"></rect> </g> </svg></div><div class="jp-carousel-info"><div class="jp-carousel-info-footer"><div class="jp-carousel-pagination-container"><div class="jp-swiper-pagination swiper-pagination"></div><div class="jp-carousel-pagination"></div></div><div class="jp-carousel-photo-title-container"><h2 class="jp-carousel-photo-caption"></h2></div><div class="jp-carousel-photo-icons-container"> <a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility"> <span class="jp-carousel-icon"> <svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"> <mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20"> <path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"></path> </mask> <g mask="url(#maskInfo)"> <rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"></rect> </g> </svg> </span> </a> <a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility"> <span class="jp-carousel-icon"> <svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"> <mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20"> <path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"></path> </mask> <g mask="url(#maskComments)"> <rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"></rect> </g> </svg> <span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span> </span> </a></div></div><div class="jp-carousel-info-extra"><div class="jp-carousel-info-content-wrapper"><div class="jp-carousel-photo-title-container"><h2 class="jp-carousel-photo-title"></h2></div><div class="jp-carousel-comments-wrapper"><div id="jp-carousel-comments-loading"> <span>Loading Comments...</span></div><div class="jp-carousel-comments"></div><div id="jp-carousel-comment-form-container"> <span id="jp-carousel-comment-form-spinner"> </span><div id="jp-carousel-comment-post-results"></div><form id="jp-carousel-comment-form"> <label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label><textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea><div id="jp-carousel-comment-form-submit-and-info-wrapper"><div id="jp-carousel-comment-form-commenting-as"><fieldset> <label for="jp-carousel-comment-form-email-field">Email (Required)</label> <input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field"/></fieldset><fieldset> <label for="jp-carousel-comment-form-author-field">Name (Required)</label> <input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field"/></fieldset><fieldset> <label for="jp-carousel-comment-form-url-field">Website</label> <input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field"/></fieldset></div> <input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment"/></div></form></div></div><div class="jp-carousel-image-meta"><div class="jp-carousel-title-and-caption"><div class="jp-carousel-photo-info"><h3 class="jp-carousel-caption" itemprop="caption description"></h3></div><div class="jp-carousel-photo-description"></div></div><ul class="jp-carousel-image-exif" style="display: none;"></ul> <a class="jp-carousel-image-download" target="_blank" style="display: none;"> <svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"> <mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18"> <path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"></path> </mask> <g mask="url(#mask0)"> <rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"></rect> </g> </svg> <span class="jp-carousel-download-text"></span> </a><div class="jp-carousel-image-map" style="display: none;"></div></div></div></div></div></div></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.forevergeek.com\/20-geeky-stocking-stuffers-for-2021\/":90283};</script> <script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"geekforever"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post,.at-above-post-page"}},{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_below,.at-below-post,.at-below-post-page"}},{"sharedock":{"counts":"none","numPreferredServices":4,"mobileButtonSize":"large","position":"bottom","theme":"transparent"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post,.at-above-post-page"}}); window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_below,.at-below-post,.at-below-post-page"}}); window.addthis_layers_tools.push({"sharedock":{"counts":"none","numPreferredServices":4,"mobileButtonSize":"large","position":"bottom","theme":"transparent"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-05693716ff6d9068c10caa888a1e37c7","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());</script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b76011022e6a2e" async="async"></script> <script type="text/javascript" id="jetpack-carousel-js-extra">var jetpackSwiperLibraryPath = {"url":"https:\/\/www.forevergeek.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","nonce":"ef45145e59","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.forevergeek.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.forevergeek.com%2F20-geeky-stocking-stuffers-for-2021%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};</script> <script type="text/javascript" id="sharing-js-js-extra">var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script type="text/javascript" id="sharing-js-js-after">var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();</script> <script type="text/javascript" id="cptch_front_end_script-js-extra">var cptch_vars = {"nonce":"5c80f4bd9a","ajaxurl":"https:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","enlarge":"0"};</script> <script src="https://stats.wp.com/e-202150.js" defer=""></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'11258759',post:'90283',tz:'-5',srv:'www.forevergeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '11258759', '90283' ]);</script> <script defer="" src="https://www.forevergeek.com/wp-content/cache/autoptimize/js/autoptimize_0190f498536240e4242412b28a3ffb23.js"></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=1&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=1&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="forevergeek_com",_audins_did=212238;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-1");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.forevergeek_com,DomainId.212238" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=1&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>