<!DOCTYPE html><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" ><head ><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /> <style id="aoatfcss" media="all">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</style><link rel="preload" as="style" media="all" href="https://www.forevergeek.com/wp-content/cache/autoptimize/css/autoptimize_c8f92fbeb9843087b8db6a32662c2e9a.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link media="all" href="https://www.forevergeek.com/wp-content/cache/autoptimize/css/autoptimize_c8f92fbeb9843087b8db6a32662c2e9a.css" rel="stylesheet" /></noscript><title>Modern Musicals That Theatre Geeks Absolutely Love | ForeverGeek</title><meta name="description" content="Musicals have been a great source of entertainment for people for a long time now. Historians say that musicals date back as far as 2,500 years ago when" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Modern Musicals That Theatre Geeks Absolutely Love | ForeverGeek" /><meta property="og:description" content="Musicals have been a great source of entertainment for people for a long time now. Historians say that musicals date back as far as 2,500 years ago when" /><meta property="og:url" content="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/" /><meta property="og:site_name" content="ForeverGeek" /><meta property="article:publisher" content="https://www.facebook.com/forevergeek.blog" /><meta property="article:published_time" content="2020-06-12T15:00:25+00:00" /><meta property="article:modified_time" content="2020-06-12T07:23:03+00:00" /><meta property="og:image" content="https://www.forevergeek.com/wp-content/media/2020/06/opera-594592_1920.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1278" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@geekforever" /><meta name="twitter:site" content="@geekforever" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.forevergeek.com/#website","url":"https://www.forevergeek.com/","name":"ForeverGeek","description":"Nerds are for Dorks","potentialAction":[{"@type":"SearchAction","target":"https://www.forevergeek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/#primaryimage","inLanguage":"en-US","url":"https://www.forevergeek.com/wp-content/media/2020/06/opera-594592_1920.jpg","width":1920,"height":1278},{"@type":"WebPage","@id":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/#webpage","url":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/","name":"Modern Musicals That Theatre Geeks Absolutely Love | ForeverGeek","isPartOf":{"@id":"https://www.forevergeek.com/#website"},"primaryImageOfPage":{"@id":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/#primaryimage"},"datePublished":"2020-06-12T15:00:25+00:00","dateModified":"2020-06-12T07:23:03+00:00","author":{"@id":"https://www.forevergeek.com/#/schema/person/5c4564b17c60ebc874c93482294c1093"},"description":"Musicals have been a great source of entertainment for people for a long time now. Historians say that musicals date back as far as 2,500 years ago when","breadcrumb":{"@id":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/"]}]},{"@type":"BreadcrumbList","@id":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.forevergeek.com/","url":"https://www.forevergeek.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/","url":"https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/","name":"Modern Musicals That Theatre Geeks Absolutely Love"}}]},{"@type":["Person"],"@id":"https://www.forevergeek.com/#/schema/person/5c4564b17c60ebc874c93482294c1093","name":"Clarence","image":{"@type":"ImageObject","@id":"https://www.forevergeek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/5479673c0665d8237fad672d9aacfc33?s=96&d=identicon&r=g","caption":"Clarence"}}]}</script> <link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Feed" href="https://www.forevergeek.com/feed/" /><link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Comments Feed" href="https://www.forevergeek.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Modern Musicals That Theatre Geeks Absolutely Love Comments Feed" href="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/feed/" /> <script type='text/javascript'>var related_posts_js_options = {"post_heading":"h4"};</script> <link rel='https://api.w.org/' href='https://www.forevergeek.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.forevergeek.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.forevergeek.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://wp.me/pLeUT-m8o' /><link rel="alternate" type="application/json+oembed" href="https://www.forevergeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forevergeek.com%2Fmodern-musicals-that-theatre-geeks-absolutely-love%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.forevergeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forevergeek.com%2Fmodern-musicals-that-theatre-geeks-absolutely-love%2F&#038;format=xml" /> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.forevergeek.com/?wordfence_lh=1&hid=E38CF9443C294C6A9B2434C0A8ADFE28');</script> <link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel="icon" href="https://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/favicon.png" /><link rel="pingback" href="https://www.forevergeek.com/xmlrpc.php" /><meta name="google-site-verification" content="oV-Ua2VGHAYSk8L0RfBgjNLNotbED-4qeoERwVuI1os" /></head><body class="post-template-default single single-post postid-85088 single-format-standard desktop content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden"><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.forevergeek.com" title="ForeverGeek"><img class="site-logo" src="https://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/logo.png?v=2" alt="ForeverGeek logo"></a></p></div><div class="widget-area header-widget-area"><section id="text-38" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="responsiveleaderboard"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-6912717002762685"
 data-ad-slot="4973535492"
 data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></section></div></div></header><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-header-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-64951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64951"><a href="https://www.forevergeek.com/category/features/"><span >Features</span></a></li><li id="menu-item-64952" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64952"><a href="https://www.forevergeek.com/category/cool-stuff-geekery/"><span >Cool Stuff &#038; Geekery</span></a></li><li id="menu-item-64953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64953"><a href="https://www.forevergeek.com/category/movies-television/"><span >Movies &#038; TV</span></a></li><li id="menu-item-64954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64954"><a href="https://www.forevergeek.com/category/anime-comics/"><span >Anime &#038; Comics</span></a></li><li id="menu-item-66222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66222"><a href="https://www.forevergeek.com/category/games/"><span >Games</span></a></li><li id="menu-item-64955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64955"><a href="#"><span >More!</span></a><ul class="sub-menu"><li id="menu-item-64960" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64960"><a href="https://www.forevergeek.com/category/general/"><span >General</span></a></li><li id="menu-item-64958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64958"><a href="https://www.forevergeek.com/about/"><span >About ForeverGeek</span></a></li><li id="menu-item-64959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64959"><a href="https://www.forevergeek.com/contact/"><span >Contact</span></a></li><li id="menu-item-84855" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84855"><a href="https://www.forevergeek.com/affiliate-referral-links/"><span >Affiliate &#038; Referral Links</span></a></li><li id="menu-item-64956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64956"><a href="https://www.forevergeek.com/terms-privacy/"><span >Terms &#038; Privacy</span></a></li></ul></li><li class="right social"><a href="https://www.pinterest.com/forevergeek/"><span class="genericon genericon-pinterest"></span></a></li><li class="right social"><a href="https://twitter.com/geekforever"><span class="genericon genericon-twitter"></span></a></li><li class="right social"><a href="https://www.facebook.com/forevergeek.blog"><span class="genericon genericon-facebook-alt"></span></a></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-85088 post type-post status-publish format-standard has-post-thumbnail category-cool-stuff-geekery category-general tag-broadway-musical tag-musical tag-theater entry"><header class="entry-header"><h1 class="entry-title">Modern Musicals That Theatre Geeks Absolutely Love</h1><p class="entry-meta"><time class="entry-time">June 12, 2020</time> by <span class="entry-author"><a href="https://www.forevergeek.com/author/clarence/" class="entry-author-link" rel="author"><span class="entry-author-name">Clarence</span></a></span> <span class="entry-comments-link"><a href="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/#respond">Leave a Comment</a></span></p></header><div class="entry-content"><p><img width="930" height="619" src="https://www.forevergeek.com/wp-content/media/2020/06/opera-594592_1920.jpg" class="attachment-large size-large wp-post-image" alt="" data-attachment-id="85091" data-permalink="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/opera-594592_1920/" data-orig-file="https://www.forevergeek.com/wp-content/media/2020/06/opera-594592_1920.jpg" data-orig-size="1920,1278" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="opera-594592_1920" data-image-description="" data-medium-file="https://www.forevergeek.com/wp-content/media/2020/06/opera-594592_1920.jpg" data-large-file="https://www.forevergeek.com/wp-content/media/2020/06/opera-594592_1920.jpg" /></p><div class="before-entry" class="widget-area"><section id="text-40" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-6912717002762685"
 data-ad-slot="3496802290"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></section></div><div class="at-above-post addthis_tool" data-url="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/"></div><p>Musicals have been a great source of entertainment for people for a long time now. Historians say that musicals date back as far as 2,500 years ago when the ancient Greeks had comedies and tragedies performed in their open-air amphitheatres. Today, there are various types of musicals with hundreds of musicals falling in various genres. We have musicals adapted from books, from films, remakes, and even modern musicals!<span id="more-85088"></span></p><p>While watching musicals live are definitely an experience, recorded copies of the play are also available to the public. Even better, some <a href="http://filmedonstage.com/news/76-free-musicals-and-plays-you-can-now-stream-during-the-coronavirus-outbreak-updating-daily">theatre productions made their musicals free to stream</a> during these times! For theatre geeks and newbies out there, we have compiled a list of musicals that you will surely love!</p><h2><a href="https://hamiltonmusical.com/">Hamilton</a></h2> <span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='640' height='360' src='https://www.youtube.com/embed/pnxDhnZuidU?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span><p>To anyone who loves theatre and musicals, <em>Hamilton</em> is definitely one of the modern musicals on their list. It is an award-winning and critically-acclaimed <a href="https://www.forevergeek.com/best-screen-stage-broadway-adaptations/">Broadway</a> musical based on Ron Chernow&#8217;s <em>Alexander Hamilton</em> biography. For a musical based on a biography, <em>Hamilton</em> is a joy to watch while still being actually informative on history. The cast is amazing, and the songs are insanely good. Where else can you watch a musical with music that has a mix of hip-hop, rap, R&amp;B and broadway music? Not only the theatre geeks love this show, but those who may not be interested in musicals but are fans of the modern music genre can appreciate <em>Hamilton</em>! With 11 Tony Awards, 7 Olivier Awards, a Grammy Award, and a Pulitzer Prize for Drama,  Lin Manuel-Miranda taking six years to write the musical was worth it.</p><h2><a href="https://dearevanhansen.com">Dear Evan Hansen</a></h2> <span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='640' height='360' src='https://www.youtube.com/embed/OMZZTrjWxt0?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span><p><em>Dear Evan Hansen</em> is another popular name we hear in the musical world. An intensely emotional musical with a very important message. The story is centered on Evan Hansen, a socially awkward boy, who writes letters to himself at the advice of his shrink. One of these letters ends up with Connor Murphy who soon commits suicide. This leads Evan Hansen to lie to Connor&#8217;s family that the both of them were best friends, a lie that soon became out of control.</p><p>Apparently loosely based on an incident from the writer, Benj Pasek&#8217;s during his time in high school, <em>Dear Evan Hansen</em> successfully shows a story about depression, suicide, and self-acceptance. Not only does <em>Dear Evan Hansen</em> have a brilliant cast that is able to act out the story well, but it also has a great line-up of songs that are catchy and impactful.</p><h2><a href="https://waitressthemusical.com">Waitress</a></h2> <span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='640' height='360' src='https://www.youtube.com/embed/qyFmHDCiHdw?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span><p><em>Waitress</em> is one of those modern musicals that was adapted from a film with the same name. The show is known for being the first Broadway show to have an all-female creative team &#8211; including the singer, Sara Bareilles, who was responsible for the music and lyrics of the show. The musical is the story of Jenna Hunterson who gets pregnant by her abusive husband. To escape her reality, she joins a baking contest and starts an affair with her doctor.</p><p>While the show generally received mixed reviews, there is no doubt that one of its best features is its score. Moreover, while it depicts a quite realistic abusive relationship, the story is overall about the women of the show. <em>Deadline</em> describes the musical perfectly,</p><blockquote><p>With its perfectly baked music and down-home feel, <em>Waitress </em>is the musical equivalent of a comforting hug — but also a swift kick in the crotch for toxic masculinity.</p></blockquote><h2><a href="https://heathersthemusical.com">Heathers: The Musical</a></h2> <span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='640' height='360' src='https://www.youtube.com/embed/Gpad8LUEwsg?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span><p>Another film musical adapted from the films is <em>Heathers: The Musical.</em> The musical was based on the 1989 classic teen comedy <em>Heathers </em>that follows the story of Veronica Sawyer, a nobody, that soon joins her high school&#8217;s top clique, the Heathers. The film is now even a cult classic. Unlike its film counterpart, <em>Heathers: The Musical</em> chose to forego the 80s theme and opted for a &#8220;timeless&#8221; setting that any teenager can relate to. With the costumes being so colorful, and the music being excellent, the musical is actually a good starter show for anyone who wants to get into theatre &#8211; especially the young ones!</p><h2><a href="https://thebookofmormonmusical.com">Book of Mormon</a></h2> <span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='640' height='360' src='https://www.youtube.com/embed/OKkLV1zE8M0?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span><p>Book of Mormon is definitely one of the best modern musicals of all time. A nine-time Tony Award winner, the <em>Book of Mormon</em> is a satirical musical of two Latter-day Saints missionaries who try to preach their faith in a remote village in Uganda. However, they soon encounter the challenges the village is experiencing such as poverty and HIV/AIDS. Despite the plot sounding so dark, the writers Robert Lopez; and <em>South Park</em>&#8216;s creators Trey Parker and Matt Stone were actually able to make<em> Book of Mormon</em> a musical comedy.</p><p>While there were concerns, the Church of Latter-day Saints responded &#8220;that <em>The Book of Mormon </em>might be entertaining for a day, but that the religion itself can change your life.&#8221; Furthermore, they have actually taken advantage of the musical and started advertising in the show&#8217;s playbills. Other than the commentary on the Mormon church, the musical is also able to comment on colonialism and gender politics with several songs such as We Are Africa and Man Up.</p><div id="amzn-assoc-ad-4dca64cf-e995-4097-9d5c-ec977e333fbf"></div><p><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&#038;adInstanceId=4dca64cf-e995-4097-9d5c-ec977e333fbf"></script></p><p>You might also enjoy:</p><h4 class="entry-title"><a class="entry-title-link" href="https://www.forevergeek.com/can-a-rewrite-save-the-spider-man-musical/" rel="bookmark">Can a Rewrite Save the Spider-Man Musical?</a></h4><h4 class="entry-title"><a class="entry-title-link" href="https://www.forevergeek.com/anime-about-music/" rel="bookmark">5 Anime About Music</a></h4><div class="at-below-post addthis_tool" data-url="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-85088" class="share-twitter sd-button share-icon no-text" href="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-85088" class="share-facebook sd-button share-icon no-text" href="https://www.forevergeek.com/modern-musicals-that-theatre-geeks-absolutely-love/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div id='jp-relatedposts' class='jp-relatedposts' ><h3 class="jp-relatedposts-headline"><em>Related</em></h3></div></div><footer class="entry-footer"><div class="after-entry" class="widget-area"><section id="text-31" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div class="addthis_responsive_sharing"></div></div></div></section></div><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.forevergeek.com/category/cool-stuff-geekery/" rel="category tag">Cool Stuff &amp; Geekery</a>, <a href="https://www.forevergeek.com/category/general/" rel="category tag">General</a></span> <span class="entry-tags">Tagged With: <a href="https://www.forevergeek.com/tag/broadway-musical/" rel="tag">Broadway Musical</a>, <a href="https://www.forevergeek.com/tag/musical/" rel="tag">musical</a>, <a href="https://www.forevergeek.com/tag/theater/" rel="tag">Theater</a></span></p></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/modern-musicals-that-theatre-geeks-absolutely-love/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.forevergeek.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="cptch_block"><span class="cptch_title">Please prove you&#039;re human<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions"> <label class="cptch_label" for="cptch_input_21"><span class="cptch_span">fou&#114;</span> <span class="cptch_span">&nbsp;&#43;&nbsp;</span> <span class="cptch_span">2</span> <span class="cptch_span">&nbsp;=&nbsp;</span> <span class="cptch_span"><input id="cptch_input_21" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span> <input type="hidden" name="cptch_result" value="OYk=" /><input type="hidden" name="cptch_time" value="1591987687" /> <input type="hidden" name="cptch_form" value="wp_comments" /> </label><span class="cptch_reload_button_wrap hide-if-no-js"> <noscript><style type="text/css">.hide-if-no-js {
								display: none !important;
							}</style></noscript> <span class="cptch_reload_button dashicons dashicons-update"></span> </span></span></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='85088' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ba7c255d67" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="248"/></p></form></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><div class='widget atf'><script src="https://www.googletagservices.com/tag/js/gpt.js">googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_ATF', [300, 250]).display();</script></div><section id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap"><div
 class="hide-on-button"
 data-hide-timeout="30"
 data-consent-expiration="180"
 id="eu-cookie-law"
><form method="post"> <input type="submit" value="Close and accept" class="accept" /></form> Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br /> To find out more, including how to control cookies, see here: <a href="https://automattic.com/cookies/" > Cookie Policy </a></div></div></section><section id="text-37" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"> <a href="https://feeds.feedburner.com/ForeverGeek"><img src="https://www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png"></a></div></div></section><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.forevergeek.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.forevergeek.com/?s={s}"></form></div></section><section id="text-36" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.forevergeek.com/best-lego-star-wars-sets/" target="_blank" rel="noopener noreferrer"><img src="https://www.forevergeek.com/wp-content/media/2017/05/Star-Wars-LEGO-Sets-You-Must-Own.png"></a> <br> <br> <br> <br><div id="zergnet-widget-14299"></div> <script language="javascript" type="text/javascript">(function() {
		var zergnet = document.createElement('script');
		zergnet.type = 'text/javascript'; zergnet.async = true;
		zergnet.src = 'https://www.zergnet.com/zerg.js?id=14299';
		var znscr = document.getElementsByTagName('script')[0];
		znscr.parentNode.insertBefore(zergnet, znscr);
	})();</script> <br> <br> <br> <br></div></div></section><section id="text-35" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.forevergeek.com/2015/11/5-geeky-cutting-boards/" target="_blank" rel="noopener noreferrer"><img src="https://www.forevergeek.com/wp-content/media/2016/05/Geeky-Cutting-Boards-1.jpg"></a> <br> <br></div></div></section><section id="text-34" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.forevergeek.com/2016/01/why-kylo-ren-is-wildly-misunderstood-and-may-be-best-star-wars-villain-yet/" target="_blank" rel="noopener noreferrer"><img src="https://www.forevergeek.com/wp-content/media/2016/05/Kylo-Ren-Best-Villain-1.jpg"></a> <a href="https://www.forevergeek.com/game-of-thrones-alignments/">Game of Thrones D&D Alignments</a></div></div></section><div class='widget btf'><script src="https://www.googletagservices.com/tag/js/gpt.js">googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_BTF', [300, 250]).display();</script></div></aside></div></div><footer class="site-footer"><div class="wrap"><p>ForeverGeek &#x000A9;&nbsp;2020 Splashpress Media</p></div></footer></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-4829570-3', 'auto');
  ga('send', 'pageview');</script> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.forevergeek.com\/modern-musicals-that-theatre-geeks-absolutely-love\/":85088};</script> <script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"geekforever"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post,.at-above-post-page"}},{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_below,.at-below-post,.at-below-post-page"}},{"sharedock":{"counts":"none","numPreferredServices":4,"mobileButtonSize":"large","position":"bottom","theme":"transparent"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post,.at-above-post-page"}}); window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_below,.at-below-post,.at-below-post-page"}}); window.addthis_layers_tools.push({"sharedock":{"counts":"none","numPreferredServices":4,"mobileButtonSize":"large","position":"bottom","theme":"transparent"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-05693716ff6d9068c10caa888a1e37c7","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());</script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b76011022e6a2e" async="async"></script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});</script> <script type='text/javascript'>var cptch_vars = {"nonce":"4b795c1ba6","ajaxurl":"https:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","enlarge":"0"};</script> <script type='text/javascript' src='https://stats.wp.com/e-202024.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'11258759',post:'85088',tz:'-4',srv:'www.forevergeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '11258759', '85088' ]);</script> <script defer src="https://www.forevergeek.com/wp-content/cache/autoptimize/js/autoptimize_795ab843ac9defd3ce12e6f0b2fb4533.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>