<!DOCTYPE html><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" ><head ><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /> <style id="aoatfcss" media="all">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</style><link rel="preload" as="style" media="all" href="https://www.forevergeek.com/wp-content/cache/autoptimize/css/autoptimize_c783ef938df4f5d9c096f9ee543aa01c.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link media="all" href="https://www.forevergeek.com/wp-content/cache/autoptimize/css/autoptimize_c783ef938df4f5d9c096f9ee543aa01c.css" rel="stylesheet" /></noscript><title>10 Dragon Ball Super scenes to rewatch for Son Goku Day | ForeverGeek</title><meta name="description" content="May 9 is Son Goku Day, and it has been 5 years since the commemoration started. Celebrate with our favorite Saiyan&#039;s 10 best moments from Dragon Ball Super." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.forevergeek.com/son-goku-day-dragon-ball-super/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="10 Dragon Ball Super scenes to rewatch for Son Goku Day | ForeverGeek" /><meta property="og:description" content="May 9 is Son Goku Day, and it has been 5 years since the commemoration started. Celebrate with our favorite Saiyan&#039;s 10 best moments from Dragon Ball Super." /><meta property="og:url" content="http://www.forevergeek.com/son-goku-day-dragon-ball-super/" /><meta property="og:site_name" content="ForeverGeek" /><meta property="article:publisher" content="https://www.facebook.com/forevergeek.blog" /><meta property="article:published_time" content="2020-05-09T17:40:20+00:00" /><meta property="article:modified_time" content="2020-05-09T17:42:04+00:00" /><meta property="og:image" content="http://www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg" /><meta property="og:image:width" content="855" /><meta property="og:image:height" content="570" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@geekforever" /><meta name="twitter:site" content="@geekforever" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.forevergeek.com/#website","url":"https://www.forevergeek.com/","name":"ForeverGeek","description":"Nerds are for Dorks","potentialAction":[{"@type":"SearchAction","target":"https://www.forevergeek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg?fit=855%2C570&ssl=1","width":855,"height":570},{"@type":"WebPage","@id":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/#webpage","url":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/","name":"10 Dragon Ball Super scenes to rewatch for Son Goku Day | ForeverGeek","isPartOf":{"@id":"https://www.forevergeek.com/#website"},"primaryImageOfPage":{"@id":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/#primaryimage"},"datePublished":"2020-05-09T17:40:20+00:00","dateModified":"2020-05-09T17:42:04+00:00","author":{"@id":"https://www.forevergeek.com/#/schema/person/2e87fa073995c145461f34067e5600a0"},"description":"May 9 is Son Goku Day, and it has been 5 years since the commemoration started. Celebrate with our favorite Saiyan's 10 best moments from Dragon Ball Super.","breadcrumb":{"@id":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://www.forevergeek.com/son-goku-day-dragon-ball-super/"]}]},{"@type":"BreadcrumbList","@id":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.forevergeek.com/","url":"https://www.forevergeek.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/","url":"http://www.forevergeek.com/son-goku-day-dragon-ball-super/","name":"10 Dragon Ball Super scenes to rewatch for Son Goku Day"}}]},{"@type":["Person"],"@id":"https://www.forevergeek.com/#/schema/person/2e87fa073995c145461f34067e5600a0","name":"Ronin","image":{"@type":"ImageObject","@id":"https://www.forevergeek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/04f5b45ebb7ca786ce6b23659657d59a?s=96&d=identicon&r=g","caption":"Ronin"}}]}</script> <link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Feed" href="https://www.forevergeek.com/feed/" /><link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; Comments Feed" href="https://www.forevergeek.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="ForeverGeek &raquo; 10 Dragon Ball Super scenes to rewatch for Son Goku Day Comments Feed" href="https://www.forevergeek.com/son-goku-day-dragon-ball-super/feed/" /> <script type='text/javascript'>var related_posts_js_options = {"post_heading":"h4"};</script> <link rel='https://api.w.org/' href='https://www.forevergeek.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.forevergeek.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.forevergeek.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://wp.me/pLeUT-m1h' /><link rel="alternate" type="application/json+oembed" href="https://www.forevergeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forevergeek.com%2Fson-goku-day-dragon-ball-super%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.forevergeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forevergeek.com%2Fson-goku-day-dragon-ball-super%2F&#038;format=xml" /> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.forevergeek.com/?wordfence_lh=1&hid=F12BFA73ED1B1C94ABA3315E00586DBD');</script> <link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><link rel="icon" href="https://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/favicon.png" /><link rel="pingback" href="https://www.forevergeek.com/xmlrpc.php" /><meta name="google-site-verification" content="oV-Ua2VGHAYSk8L0RfBgjNLNotbED-4qeoERwVuI1os" /> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> </head><body class="post-template-default single single-post postid-84647 single-format-standard desktop content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden"><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.forevergeek.com" title="ForeverGeek"><img class="site-logo" src="https://www.forevergeek.com/wp-content/themes/fg-news-pro-2/images/logo.png?v=2" alt="ForeverGeek logo"></a></p></div><div class="widget-area header-widget-area"><section id="text-38" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="responsiveleaderboard"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-6912717002762685"
 data-ad-slot="4973535492"
 data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></section></div></div></header><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-header-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-64951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64951"><a href="https://www.forevergeek.com/category/features/"><span >Features</span></a></li><li id="menu-item-64952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64952"><a href="https://www.forevergeek.com/category/cool-stuff-geekery/"><span >Cool Stuff &#038; Geekery</span></a></li><li id="menu-item-64953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64953"><a href="https://www.forevergeek.com/category/movies-television/"><span >Movies &#038; TV</span></a></li><li id="menu-item-64954" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64954"><a href="https://www.forevergeek.com/category/anime-comics/"><span >Anime &#038; Comics</span></a></li><li id="menu-item-66222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66222"><a href="https://www.forevergeek.com/category/games/"><span >Games</span></a></li><li id="menu-item-64955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-64955"><a href="#"><span >More!</span></a><ul class="sub-menu"><li id="menu-item-64960" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64960"><a href="https://www.forevergeek.com/category/general/"><span >General</span></a></li><li id="menu-item-64957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64957"><a href="https://www.forevergeek.com/archive/"><span >Archives</span></a></li><li id="menu-item-64958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64958"><a href="https://www.forevergeek.com/about/"><span >About ForeverGeek</span></a></li><li id="menu-item-64959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64959"><a href="https://www.forevergeek.com/contact/"><span >Contact</span></a></li><li id="menu-item-64956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64956"><a href="https://www.forevergeek.com/terms-privacy/"><span >Terms &#038; Privacy</span></a></li></ul></li><li class="right social"><a href="https://www.pinterest.com/forevergeek/"><span class="genericon genericon-pinterest"></span></a></li><li class="right social"><a href="https://twitter.com/geekforever"><span class="genericon genericon-twitter"></span></a></li><li class="right social"><a href="https://www.facebook.com/forevergeek.blog"><span class="genericon genericon-facebook-alt"></span></a></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-84647 post type-post status-publish format-standard has-post-thumbnail category-anime-comics tag-anime tag-dragon-ball tag-dragon-ball-super entry"><header class="entry-header"><h1 class="entry-title">10 Dragon Ball Super scenes to rewatch for Son Goku Day</h1><p class="entry-meta"><time class="entry-time">May 9, 2020</time> by <span class="entry-author"><a href="https://www.forevergeek.com/author/ronin/" class="entry-author-link" rel="author"><span class="entry-author-name">Ronin</span></a></span> <span class="entry-comments-link"><a href="https://www.forevergeek.com/son-goku-day-dragon-ball-super/#respond">Leave a Comment</a></span></p></header><div class="entry-content"><p><img width="855" height="570" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg?fit=855%2C570&amp;ssl=1" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="84651" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-thumb/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg?fit=855%2C570&amp;ssl=1" data-orig-size="855,570" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku thumb" data-image-description="" data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg?fit=855%2C570&amp;ssl=1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-thumb.jpg?fit=855%2C570&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></p><div class="before-entry" class="widget-area"><section id="text-40" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-6912717002762685"
 data-ad-slot="3496802290"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></section></div><div class="at-above-post addthis_tool" data-url="https://www.forevergeek.com/son-goku-day-dragon-ball-super/"></div><p><a href="https://www.forevergeek.com/geek-holiday-calendar/">May 9 is Son Goku Day!</a> It has been five years since the Dragon Ball franchise&#8217;s main character returned for a brand-new series: Dragon Ball Super. Just when you thought that our favorite Saiyan has already reached his limit, he just breaks it to ascend to a whole new level.</p><p>To celebrate Son Goku Day, here are his best scenes in the anime series. If you haven&#8217;t seen Dragon Ball Super, you&#8217;ve been warned: spoilers abound this list!</p><h3>1) Goku leaves his family to practice at the first opportunity</h3><h3><img data-attachment-id="84652" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-action/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?fit=1500%2C1061&amp;ssl=1" data-orig-size="1500,1061" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku action" data-image-description data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?fit=470%2C332&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?fit=930%2C658&amp;ssl=1" class="size-full wp-image-84652 aligncenter jetpack-lazy-image" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?resize=1500%2C1061" alt width="1500" height="1061" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?resize=1500%2C1061&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84652" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-action/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?fit=1500%2C1061&amp;ssl=1" data-orig-size="1500,1061" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku action" data-image-description="" data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?fit=470%2C332&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?fit=930%2C658&amp;ssl=1" class="size-full wp-image-84652 aligncenter" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-action.jpg?resize=1500%2C1061" alt="" width="1500" height="1061" data-recalc-dims="1" /></noscript></h3><p><em><a href="https://www.amazon.com/Bandai-Tamashii-Nations-Figuarts-Saiyan/dp/B078K3YWN3/ref=sr_1_58?dchild=1&amp;keywords=tamashii+dragon+ball+super&amp;qid=1589020175&amp;sr=8-58" target="_blank" rel="noopener noreferrer">Get the Son Goku figure here.</a></em></p><p>The series opens with Son Goku working as a farmer, because, well, saving the world does not actually earn you money. But when Mr. Satan actually gives him 100 million zeni for beating Buu (Dragon Ball Z&#8217;s final main villain), he immediately gives the money to his wife Chi-Chi and dons his iconic orange uniform to train at King Kai&#8217;s planet. Oh his priorities.</p><h3>2) Goku turns into Super Saiyan God</h3><h3><img data-attachment-id="84653" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/battle-of-the-gods/" data-orig-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?fit=872%2C581&amp;ssl=1" data-orig-size="872,581" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="battle of the gods" data-image-description data-medium-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?fit=872%2C581&amp;ssl=1" class="size-full wp-image-84653 aligncenter jetpack-lazy-image" src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?resize=872%2C581" alt width="872" height="581" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?resize=872%2C581&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84653" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/battle-of-the-gods/" data-orig-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?fit=872%2C581&amp;ssl=1" data-orig-size="872,581" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="battle of the gods" data-image-description="" data-medium-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?fit=872%2C581&amp;ssl=1" class="size-full wp-image-84653 aligncenter" src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/battle-of-the-gods.jpg?resize=872%2C581" alt="" width="872" height="581" data-recalc-dims="1" /></noscript></h3><p><em><a href="https://www.amazon.com/Bandai-Tamashii-Nations-Figuarts-Saiyan/dp/B072JF5173/ref=sr_1_33?dchild=1&amp;keywords=tamashii+dragon+ball+super&amp;qid=1589020087&amp;sr=8-33" target="_blank" rel="noopener noreferrer">Get the Super Saiyan God Goku figure here</a></em></p><p>To fight Beerus, the God of Destruction, Son Goku actually turned into a Super Saiyan God! Unlocked through a ritual with six Saiyans, the Super Saiyan God transformation turned Goku&#8217;s base form&#8217;s eyes and hair into red. But if this is only a base transformation, that could only mean&#8230;</p><h3>3) Super Saiyan God Super Saiyan exists</h3><p><img data-attachment-id="84654" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/super-saiyan-god-super-saiyan-goku/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?fit=973%2C649&amp;ssl=1" data-orig-size="973,649" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super saiyan god super saiyan goku" data-image-description data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?fit=930%2C620&amp;ssl=1" class="size-full wp-image-84654 aligncenter jetpack-lazy-image" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?resize=973%2C649" alt width="973" height="649" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?resize=973%2C649&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84654" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/super-saiyan-god-super-saiyan-goku/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?fit=973%2C649&amp;ssl=1" data-orig-size="973,649" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super saiyan god super saiyan goku" data-image-description="" data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?fit=930%2C620&amp;ssl=1" class="size-full wp-image-84654 aligncenter" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-goku.jpg?resize=973%2C649" alt="" width="973" height="649" data-recalc-dims="1" /></noscript><em><a href="https://www.amazon.com/Tamashii-Nations-Bandai-Figuarts-Saiyan/dp/B07N864FLL/ref=sr_1_2?crid=28JQVQRXKEX0C&amp;dchild=1&amp;keywords=super+saiyan+god+goku+action+figure&amp;qid=1589019338&amp;sprefix=super+saiyan+god+%2Caps%2C387&amp;sr=8-2" target="_blank" rel="noopener noreferrer">Get the Super Saiyan God Super Saiyan Goku figure here</a></em></p><p>Son Goku, and eventually Vegeta, look exactly like their yellow-haired Super Saiyan forms. Visually, the difference is the hair color, but the power level immensely higher. Super Saiyan God Super Saiyan is quite a mouthful, so the characters decided to call it Super Saiyan Blue instead. How convenient.</p><h3>4) Goku gets an evil doppelganger</h3><p><img data-attachment-id="84656" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/goku-black/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?fit=1061%2C708&amp;ssl=1" data-orig-size="1061,708" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="goku black" data-image-description data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?fit=470%2C314&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?fit=930%2C621&amp;ssl=1" class="size-full wp-image-84656 aligncenter jetpack-lazy-image" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?resize=1061%2C708" alt width="1061" height="708" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?resize=1061%2C708&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84656" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/goku-black/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?fit=1061%2C708&amp;ssl=1" data-orig-size="1061,708" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="goku black" data-image-description="" data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?fit=470%2C314&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?fit=930%2C621&amp;ssl=1" class="size-full wp-image-84656 aligncenter" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/goku-black.jpg?resize=1061%2C708" alt="" width="1061" height="708" data-recalc-dims="1" /></noscript> <em><a href="https://www.amazon.com/Bandai-Tamashii-Nations-Figuarts-Dragon/dp/B075YZPM1P/ref=sr_1_186?crid=28JQVQRXKEX0C&amp;dchild=1&amp;keywords=super+saiyan+god+goku+action+figure&amp;qid=1589019511&amp;sprefix=super+saiyan+god+%2Caps%2C387&amp;sr=8-186" target="_blank" rel="noopener noreferrer">Get the Goku Black figure here</a></em></p><p>While Son Goku doesn&#8217;t exactly turn evil, a version of him in a different timeline gets his body switched with evil Supreme Kai&#8217;s apprentice Zamasu. The main evil duo of Future Trunk&#8217;s arc features Goku Black, who can also turn himself to a pink-haired Super Saiyan.</p><h3>5) Vegito returns</h3><p><img data-attachment-id="84658" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/super-saiyan-god-super-saiyan-vegito/" data-orig-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?fit=1143%2C762&amp;ssl=1" data-orig-size="1143,762" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super saiyan god super saiyan vegito" data-image-description data-medium-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?fit=930%2C620&amp;ssl=1" class="size-full wp-image-84658 aligncenter jetpack-lazy-image" src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?resize=1143%2C762" alt width="1143" height="762" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?resize=1143%2C762&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84658" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/super-saiyan-god-super-saiyan-vegito/" data-orig-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?fit=1143%2C762&amp;ssl=1" data-orig-size="1143,762" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super saiyan god super saiyan vegito" data-image-description="" data-medium-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?fit=930%2C620&amp;ssl=1" class="size-full wp-image-84658 aligncenter" src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-god-super-saiyan-vegito.jpg?resize=1143%2C762" alt="" width="1143" height="762" data-recalc-dims="1" /></noscript></p><p><em><a href="https://www.amazon.com/Banpresto-Dragon-Kamehameha-Saiyan-Vegito/dp/B078NJF567/ref=sr_1_8?dchild=1&amp;keywords=vegito&amp;qid=1589020460&amp;sr=8-8">Get the Super Saiyan Blue Vegito figure here</a></em></p><p>With Son Goku and Vegeta up against a fused version of Zamasu and Goku Black, the two Saiyans had to swallow their individualistic pride to fuse anew using potara earrings. The result is Vegito&#8217;s return, now with the power of Super Saiyan Blue. Now they didn&#8217;t play around like they did back when they faced Buu in Dragon Ball Z.</p><h3>6) Goku&#8217;s spirit bomb, well, bombs</h3><p><img data-attachment-id="84660" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-genki-dama/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?fit=1124%2C750&amp;ssl=1" data-orig-size="1124,750" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku genki dama" data-image-description data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?fit=470%2C314&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?fit=930%2C621&amp;ssl=1" class="size-full wp-image-84660 aligncenter jetpack-lazy-image" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?resize=1124%2C750" alt width="1124" height="750" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?resize=1124%2C750&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84660" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-genki-dama/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?fit=1124%2C750&amp;ssl=1" data-orig-size="1124,750" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku genki dama" data-image-description="" data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?fit=470%2C314&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?fit=930%2C621&amp;ssl=1" class="size-full wp-image-84660 aligncenter" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-genki-dama.jpg?resize=1124%2C750" alt="" width="1124" height="750" data-recalc-dims="1" /></noscript></p><p><em><a href="https://www.amazon.com/Banpresto-Dragon-Figure-Energy-Special/dp/B01ALHMHCA/ref=sr_1_209?dchild=1&amp;keywords=son+goku&amp;qid=1589018540&amp;sr=8-209" target="_blank" rel="noopener noreferrer">Get the Son Goku Spirit Bomb figure here</a></em></p><p>The Tournament of Power saw Goku&#8217;s Universe 7 fierce warriors from different universes in a battle royale for survival. Goku turned to his trusty technique, the spirit bomb, to gather energy from his teammates into a giant ball of destructive power. It doesn&#8217;t work this time, however, as the spirit bomb blows in front of Goku, instead. However, this blast helps actually triggers a new form.</p><h3>7) Goku gets ultra what?</h3><p><img data-attachment-id="84659" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-incomplete-ultra-instinct/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?fit=1615%2C1076&amp;ssl=1" data-orig-size="1615,1076" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku incomplete ultra instinct" data-image-description data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?fit=930%2C620&amp;ssl=1" class="alignnone size-full wp-image-84659 jetpack-lazy-image" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?resize=1615%2C1076" alt width="1615" height="1076" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?resize=1615%2C1076&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84659" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-incomplete-ultra-instinct/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?fit=1615%2C1076&amp;ssl=1" data-orig-size="1615,1076" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku incomplete ultra instinct" data-image-description="" data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?fit=930%2C620&amp;ssl=1" class="alignnone size-full wp-image-84659" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-incomplete-ultra-instinct.jpg?resize=1615%2C1076" alt="" width="1615" height="1076" data-recalc-dims="1" /></noscript></p><p><em><a href="https://www.amazon.com/Banpresto-35889-Dragon-Instinct-Sign/dp/B07NJR8ZZS/ref=sr_1_138?dchild=1&amp;keywords=son+goku&amp;qid=1589019108&amp;sr=8-138" target="_blank" rel="noopener noreferrer">Get the Incomplete Ultra Instinct Goku figure here</a></em></p><p>Here, Goku transcends anew, this time tapping into a power that even the Gods of Destruction themselves can&#8217;t easily reach: ultra instinct. The spirit bomb unlocks its incomplete version, where his body automatically evades attacks while his eyes and hair show a silver glow.</p><h3>8) Goku completes ultra instinct</h3><p><img data-attachment-id="84663" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/ultra-instinct-goku-2/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?fit=1061%2C708&amp;ssl=1" data-orig-size="1061,708" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ultra instinct goku" data-image-description data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?fit=470%2C314&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?fit=930%2C621&amp;ssl=1" class="alignnone size-full wp-image-84663 jetpack-lazy-image" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?resize=1061%2C708" alt width="1061" height="708" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?resize=1061%2C708&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84663" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/ultra-instinct-goku-2/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?fit=1061%2C708&amp;ssl=1" data-orig-size="1061,708" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ultra instinct goku" data-image-description="" data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?fit=470%2C314&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?fit=930%2C621&amp;ssl=1" class="alignnone size-full wp-image-84663" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/ultra-instinct-goku-1.jpg?resize=1061%2C708" alt="" width="1061" height="708" data-recalc-dims="1" /></noscript></p><p><em><a href="https://www.amazon.com/TAMASHII-NATIONS-Figuarts-Instinct-Dragon/dp/B07ZJJR4GP/ref=sr_1_8?dchild=1&amp;keywords=son+goku&amp;qid=1589017256&amp;sr=8-8">Get the Ultra Instinct Goku figure here</a></em></p><p>Goku&#8217;s hair and eyes turn full silver in this form where his body automatically attacks and defends. He almost beats the ever-powerful Jiren in this form, until his power runs out.</p><h3>9) Goku, Freeza, Android 18 vs Jiren</h3><p><img data-attachment-id="84665" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-battle-damage/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?fit=756%2C504&amp;ssl=1" data-orig-size="756,504" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku battle damage" data-image-description data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?fit=756%2C504&amp;ssl=1" class="alignnone size-full wp-image-84665 jetpack-lazy-image" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?resize=756%2C504" alt width="756" height="504" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?resize=756%2C504&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84665" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/son-goku-battle-damage/" data-orig-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?fit=756%2C504&amp;ssl=1" data-orig-size="756,504" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="son goku battle damage" data-image-description="" data-medium-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?fit=470%2C313&amp;ssl=1" data-large-file="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?fit=756%2C504&amp;ssl=1" class="alignnone size-full wp-image-84665" src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2020/05/son-goku-battle-damage.jpg?resize=756%2C504" alt="" width="756" height="504" data-recalc-dims="1" /></noscript></p><p><em>Get the <a href="https://www.amazon.com/Son-Goku-Dragonball-Fighters-Figurine/dp/B07QF34KW3/ref=sr_1_141?dchild=1&amp;keywords=son+goku&amp;qid=1589019108&amp;sr=8-141" target="_blank" rel="noopener noreferrer">Son Goku</a> and <a href="https://www.amazon.com/Dragon-Ball-Banpresto-Makers-Figure/dp/B07FPHYF37/ref=sr_1_39?dchild=1&amp;keywords=super+saiyan+son+goku+dragon+ball+super&amp;qid=1589018665&amp;sr=8-39" target="_blank" rel="noopener noreferrer">Super Saiyan Son Goku figures</a></em></p><p>If you have to watch only one Dragon Ball scene for Son Goku Day, this has to be it.</p><p>Drained, Goku teams up with two of his former foes, charging with Freeza at the front while Android 18 provided long range support from the back. It&#8217;s a strange team up, considering that Goku and Freeza still hate each other guts. Near the end, Goku&#8217;s Super Saiyan form pulsated as he helped Freeza push Jiren out of the battle stadium, until he finally transformed at the last moment. That&#8217;s chilling since Goku unlocked his Super Saiyan powers when he fought Freeza in Planet Namek.</p><h3>10. Gogeta becomes canon</h3><p><img data-attachment-id="84666" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/super-saiyan-blue-gogeta/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?fit=1376%2C973&amp;ssl=1" data-orig-size="1376,973" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super saiyan blue gogeta" data-image-description data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?fit=470%2C332&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?fit=930%2C658&amp;ssl=1" class="alignnone size-full wp-image-84666 jetpack-lazy-image" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?resize=1376%2C973" alt width="1376" height="973" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?resize=1376%2C973&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="84666" data-permalink="https://www.forevergeek.com/son-goku-day-dragon-ball-super/super-saiyan-blue-gogeta/" data-orig-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?fit=1376%2C973&amp;ssl=1" data-orig-size="1376,973" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super saiyan blue gogeta" data-image-description="" data-medium-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?fit=470%2C332&amp;ssl=1" data-large-file="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?fit=930%2C658&amp;ssl=1" class="alignnone size-full wp-image-84666" src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2020/05/super-saiyan-blue-gogeta.jpg?resize=1376%2C973" alt="" width="1376" height="973" data-recalc-dims="1" /></noscript></p><p><em><a href="https://www.amazon.com/Tamashii-Nations-Bandai-Figuarts-Saiyan/dp/B07L2DXVL5/ref=sr_1_1?dchild=1&amp;keywords=gogeta&amp;qid=1589017943&amp;sr=8-1">Get the Super Saiyan Blue Gogeta figure here</a></em></p><p>While not part of the normal season, the movie Dragon Ball Super: Broly made the legendary super saiyan, Broly, an official character in Goku&#8217;s universe. All Dragon Ball Z films in the 90s were not canon apparently, since they don&#8217;t fit the anime and manga&#8217;s continuity, but Broly was one of the reccuring villains in those stories.</p><p>In this movie, another fan favorite also got his canon introduction: Gogeta.</p><p>With Goku and Vegeta unable to beat Broly on their own, they had to learn the fusion dance from Piccolo. After two failed tries, the newly-fused Gogeta proved to be powerful enough to overwhelm their new foe. The fight scene between Broly and Gogeta here is simply one of the best and it can definitely make your Son Goku Day celebration better.</p><div class="at-below-post addthis_tool" data-url="https://www.forevergeek.com/son-goku-day-dragon-ball-super/"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-84647" class="share-twitter sd-button share-icon no-text" href="https://www.forevergeek.com/son-goku-day-dragon-ball-super/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-84647" class="share-facebook sd-button share-icon no-text" href="https://www.forevergeek.com/son-goku-day-dragon-ball-super/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div id='jp-relatedposts' class='jp-relatedposts' ><h3 class="jp-relatedposts-headline"><em>Related</em></h3></div></div><footer class="entry-footer"><div class="after-entry" class="widget-area"><section id="text-31" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div class="addthis_responsive_sharing"></div></div></div></section></div><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.forevergeek.com/category/anime-comics/" rel="category tag">Anime &amp; Comics</a></span> <span class="entry-tags">Tagged With: <a href="https://www.forevergeek.com/tag/anime/" rel="tag">anime</a>, <a href="https://www.forevergeek.com/tag/dragon-ball/" rel="tag">dragon ball</a>, <a href="https://www.forevergeek.com/tag/dragon-ball-super/" rel="tag">dragon ball super</a></span></p></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/son-goku-day-dragon-ball-super/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.forevergeek.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="cptch_block"><span class="cptch_title">Please prove you&#039;re human<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions"> <label class="cptch_label" for="cptch_input_55"><span class="cptch_span">&#101;i&#103;&#104;&#116;</span> <span class="cptch_span">&nbsp;&times;&nbsp;</span> <span class="cptch_span">3</span> <span class="cptch_span">&nbsp;=&nbsp;</span> <span class="cptch_span"><input id="cptch_input_55" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span> <input type="hidden" name="cptch_result" value="q1v5" /><input type="hidden" name="cptch_time" value="1589059522" /> <input type="hidden" name="cptch_form" value="wp_comments" /> </label><span class="cptch_reload_button_wrap hide-if-no-js"> <noscript><style type="text/css">.hide-if-no-js {
								display: none !important;
							}</style></noscript> <span class="cptch_reload_button dashicons dashicons-update"></span> </span></span></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='84647' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="afdd1fb805" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="65"/></p></form></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><div class='widget atf'><script src="https://www.googletagservices.com/tag/js/gpt.js">googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_ATF', [300, 250]).display();</script></div><section id="text-37" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"> <a href="https://feeds.feedburner.com/ForeverGeek"><img src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/www.forevergeek.com/wp-content/media/2015/10/forevergeek-newsfeed.png?ssl=1" data-recalc-dims="1"></noscript></a></div></div></section><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.forevergeek.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.forevergeek.com/?s={s}"></form></div></section><section id="text-36" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.forevergeek.com/best-lego-star-wars-sets/" target="_blank" rel="noopener noreferrer"><img src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2017/05/Star-Wars-LEGO-Sets-You-Must-Own.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2017/05/Star-Wars-LEGO-Sets-You-Must-Own.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2017/05/Star-Wars-LEGO-Sets-You-Must-Own.png?ssl=1" data-recalc-dims="1"></noscript></a> <br> <br> <br> <br><div id="zergnet-widget-14299"></div> <script language="javascript" type="text/javascript">(function() {
		var zergnet = document.createElement('script');
		zergnet.type = 'text/javascript'; zergnet.async = true;
		zergnet.src = 'https://www.zergnet.com/zerg.js?id=14299';
		var znscr = document.getElementsByTagName('script')[0];
		znscr.parentNode.insertBefore(zergnet, znscr);
	})();</script> <br> <br> <br> <br></div></div></section><section id="text-35" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.forevergeek.com/2015/11/5-geeky-cutting-boards/" target="_blank" rel="noopener noreferrer"><img src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2016/05/Geeky-Cutting-Boards-1.jpg?ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2016/05/Geeky-Cutting-Boards-1.jpg?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/www.forevergeek.com/wp-content/media/2016/05/Geeky-Cutting-Boards-1.jpg?ssl=1" data-recalc-dims="1"></noscript></a> <br> <br></div></div></section><section id="text-34" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.forevergeek.com/2016/01/why-kylo-ren-is-wildly-misunderstood-and-may-be-best-star-wars-villain-yet/" target="_blank" rel="noopener noreferrer"><img src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2016/05/Kylo-Ren-Best-Villain-1.jpg?ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2016/05/Kylo-Ren-Best-Villain-1.jpg?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.forevergeek.com/wp-content/media/2016/05/Kylo-Ren-Best-Villain-1.jpg?ssl=1" data-recalc-dims="1"></noscript></a> <a href="https://www.forevergeek.com/game-of-thrones-alignments/">Game of Thrones D&D Alignments</a></div></div></section><div class='widget btf'><script src="https://www.googletagservices.com/tag/js/gpt.js">googletag.pubads().definePassback('/8095840/67.forevergeek.com_300x250_BTF', [300, 250]).display();</script></div></aside></div></div><footer class="site-footer"><div class="wrap"><p>ForeverGeek &#x000A9;&nbsp;2020 Splashpress Media</p></div></footer></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-4829570-3', 'auto');
  ga('send', 'pageview');</script> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.forevergeek.com\/son-goku-day-dragon-ball-super\/":84647};</script> <script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"geekforever"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"data_ga_property":"UA-4829570-3","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post,.at-above-post-page"}},{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_below,.at-below-post,.at-below-post-page"}},{"sharedock":{"counts":"none","numPreferredServices":4,"mobileButtonSize":"large","position":"bottom","theme":"transparent"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post,.at-above-post-page"}}); window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_below,.at-below-post,.at-below-post-page"}}); window.addthis_layers_tools.push({"sharedock":{"counts":"none","numPreferredServices":4,"mobileButtonSize":"large","position":"bottom","theme":"transparent"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-05693716ff6d9068c10caa888a1e37c7","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());</script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54b76011022e6a2e" async="async"></script> <script type='text/javascript'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","nonce":"186aca48cc","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.forevergeek.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.forevergeek.com%2Fson-goku-day-dragon-ball-super%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});</script> <script type='text/javascript'>var cptch_vars = {"nonce":"a216c9224f","ajaxurl":"https:\/\/www.forevergeek.com\/wp-admin\/admin-ajax.php","enlarge":"0"};</script> <script type='text/javascript' src='https://stats.wp.com/e-202019.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'11258759',post:'84647',tz:'-4',srv:'www.forevergeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '11258759', '84647' ]);</script> <script defer src="https://www.forevergeek.com/wp-content/cache/autoptimize/js/autoptimize_700bda4c25d302d4ce8d5e480a7a5387.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>